Error while building OpenFire 3.9.3

Hi all

I’m trying to build the newest version of OpenFire but I got an error. I googled it a few days but there is no answer until now

C:\openfire_src\build>ant

Buildfile: C:\openfire_src\build\build.xml

init:

compile:

[javac] Compiling 72 source files to C:\openfire_src\work\classes

[javac] warning: [options] bootstrap class path not set in conjunction with

-source 1.5

[javac] C:\openfire_src\src\java\org\jivesoftware\util\CertificateManager.ja

va:275: error: incompatible types

[javac] ASN1Encodable o = otherNameSeq.getObject

At(1);

[javac]

^

[javac] required: ASN1Encodable

[javac] found: DEREncodable

[javac] C:\openfire_src\src\java\org\jivesoftware\util\CertificateManager.ja

va:464: error: cannot find symbol

[javac] deros.writeObject(csr.toASN1Primitive());

[javac] ^

[javac] symbol: method toASN1Primitive()

[javac] location: variable csr of type PKCS10CertificationRequest

[javac] C:\openfire_src\src\java\org\jivesoftware\util\CertificateManager.ja

va:920: error: no suitable constructor found for GeneralNames(GeneralName[])

[javac] GeneralNames subjectAltNames = new GeneralNames(new GeneralN

ame[]{othernameGN});

[javac] ^

[javac] constructor GeneralNames.GeneralNames(ASN1Sequence) is not appli

cable

[javac] (actual argument GeneralName[] cannot be converted to ASN1Sequ

ence by method invocation conversion)

[javac] constructor GeneralNames.GeneralNames(GeneralName) is not applic

able

[javac] (actual argument GeneralName[] cannot be converted to GeneralN

ame by method invocation conversion)

[javac] Note: Some input files use or override a deprecated API.

[javac] Note: Recompile with -Xlint:deprecation for details.

[javac] Note: Some input files use unchecked or unsafe operations.

[javac] Note: Recompile with -Xlint:unchecked for details.

[javac] 3 errors

[javac] 1 warning

BUILD FAILED

C:\openfire_src\build\build.xml:275: Compile failed; see the compiler error outp

ut for details.

Total time: 1 second

Could you please tell me how to make it work? I followed OpenFire build instruction to build the source and plugins but I got the same error.

Hello what is your version jvm?

Hi,

I’m using java 1.7.0 and Windows 7 64 bit OS

Thanks

Any help?

Dear all,

It’s so strange but I think now the problem was solved. I just at the openfire source to my Eclipse and the problem has gone