powered by Jive Software

Errors in sending and receiving messages with spark

Hello, I can’t send messages in chat windows because when I press the enter key nothing happens.

Futhermore, when someone writes to me, window chat opens but it’s empty, if I close it and reopen it I see the message.

I have 2.8.2, I tried 2.8.0 and online versions (with profile deleted) but nothing changes. Other coworkers does not have any problem.

Someone has an idea about it?

Thanks bye

Try clean reinstall (uninstall, delete all left over Spark folders in Program files and in AppData\Roaming). This will delete your profile again and history will be lost (you probably already know it). Then install 2.8.2.

I already tried deleting all files and profile, anyway I solved installing right clicking as administrator (Windows 7).

Thanks bye

I see. Btw, does your Windows user has administrative rights?

Yes

Ok. That must be Windows UAC issue. Even when you have administrative rights you can’t easily modify Program files contents. When you install like that in reality Windows installs application into VirtualStore in your profile (appdata), though it looks like you have it installed in Program files (some kind of virtual links). And this creates problems with Spark probably. Most programs still ask for admin credentials approval (uac prompt). But Spark’s installer doesn’t do that (since one install4j version a few years ago), that’s why you had to use Run as admin manually.