powered by Jive Software

Every time I stop and restart Openfire, I am unable to log back into Spark or the Admin Console

Openfire 4.1.1 on Windows Server 2012. After stopping Openfire and restarting, I am unable to log back into Spark or the Admin Console. I have to end up uninstalling/reinstalling Openfire to get it working again. I am using the embedded database and ldap. The first time I install and configure, everything works great, but if I reboot the server or stop the service, I can never get it to work again. Any help would be greatly appreciated.

Joe

this is likely a UAC issue. are you using the openfire service? you can also try installing to c:\openfire instead of the c:\program files

1 Like

Looks like UAC issue indeed. From the Openfire: Installation Guide

Windows

Run the Openfire installer. The application will be installed to C:\Program Files\Openfire by default.

Note: On Windows systems we suggest using a service to run Openfire (read the Windows Service section below). When using Openfire Launcher on Windows Vista or newer with UAC protection enabled, it has to be run with Run as administrator option, to be able to write changes to config and embedded database (if used) stored in C:\Program files\Openfire\ folder.

It doesn’t matter whether I run as administrator or not. The same thing happens. I even disabled UAC on the server I still have the same problem. It has to be something more than UAC.

You do run it with a launcher? When you reboot and run it again, when you go to Admin Console’s address, does it provides you the setup page again? Then it is an UAC/permission issue. You can just install the service and it shouldn’t matter anymore then. Or try installing it into C:\Openfire\

No, I am installing the service. After reboot, when I go to the admin console, it brings me to the login screen, and my login that worked before the reboot doesn’t work, and I can’t log into Spark either. I have been installing it in C:\Openfire. It doesn’t seem to matter where I install it. I have reinstalled Openfire probable 50 times this week and nothing ever changes. This has to be a bug or something.

When you go though a setup for the first time and it shows the Login to Admin Console button at the end of setup, are you able to login at that point? Do you use ‘admin’ username to login? What error does it give when you are not able to login? You can also check Openfire\logs for some clues.

I have the same question I test many methods database embed sql or mysql server changing document permision nothing helped

And no event viewer error log or information no error log in openfire log file and also installing all java update and jdk

with no luck