powered by Jive Software

Failed to Establish Chain from Reply - GlobalSign nv-sa

Server Properties
Server Uptime:
46 minutes – started Nov 17, 2009 3:14:22 PM
Version:
Openfire 3.6.4
Server Directory:
/home/cta/cta-openfire
Server Name:
Found RSA certificate that is not valid for the server domain. commitmenttitle.com
Environment
Java Version:
1.6.0_03 Sun Microsystems Inc. – Java HotSpot™ Server VM
Appserver:
jetty-6.1.x
Host Name:
cosmos.constellationmedia.com
OS / Hardware:
Linux / i386

I’m trying to import my signed cert via import-certificate.jsp, but keep getting “failed to establish chain from reply”. I imported globalsign’s root cert into the keystore:

./keytool -import -alias globalsignext -keystore …/…/resources/security/truststore -file …/…/resources/security/globalsign-extended.cer./keytool -import -alias globalsign -keystore …/…/resources/security/truststore -file …/…/resources/security/globalsign.cer

The .cer files were downloaded from http://www.globalsign.com/support/root-certificate/root-globalsign-rc2.php and http://www.globalsign.com/support/root-certificate/root-globalsign.php, respectively.

Clearly, I don’t understand how this all works, because I still get the same error. If someone can point me in the right direction, that would be great.

Can someone take a look at this? I really need to get SSL working.

Anyone? Anyone at all? I am unable to resolve this issue properly after months of research and work on it.