powered by Jive Software

"Failed to load Main-Class manifest..." java error when trying to install Jitsivideobridge plugin

Hi. I was hoping someone could give me a bit of assistance. I am running OpenFire on a Windows 2008 R2 server and all seems happy on the server side. I’ve installed all the plug-ins I need, and some that I don’t.

On the client side, I use Windows 8.1 and Spark as my IM client. When I load up Chrome and go to https://your_server:7443/jitsi/apps/spark/jitsivideobridge-plugin.jar to get the plug-in, first I get a certificate message. No big deal, I can bypass that. But when I do and it pulls the .jar file from the server (which it does and places it locally), I get the Java Virtual Machine Launcher message “Failed to load Main-Class manifest attribute from \jitsivideobridge-plugin.jar”

I’ve read something about creating a file for the Main-Class manifest, but the details, such as where to create the file, were not obvious to a neophite like myself.

Any assistance would be appreciateed.

Thanks.

Marc

http://www.igniterealtime.org/builds/sparkplug_kit/docs/latest/sparkplug_dev_gui de.html

Look at the section on how to install a sparkplug

OK, let me explain…

I am not a programmer and don’t know much about building Java apps or plug-ins. This should be relatively simple… I installed an add-on that is suppose to work. and it does not. The included files should have worked as there were no instructions on additional information to add or build.

Quite honestly, I’m not even certain how the video is suppose to work, through Chrome or through Spark. My guess is through Chrome because of the videos on the site, but it didn’t saay how to access the feature.

So let me explain as well. I am a simple programmer and not a paid technical author. I pointed you at a link that has a section which explains how to install a Spark Plugin. I was not expecting you to build your own plugin

If you want to know the plugin works, read this link

http://community.igniterealtime.org/community/support/jitsi_videobridge_plugin/o fmeet?view=blog

and this

http://community.igniterealtime.org/community/support/jitsi_videobridge_plugin?v iew=blog

While I have not yet had success with the client side, the server seems to load the Videobridge component session. The problem with this, is that the session apparently requires that an account be continually logged in. In the real world, this is bad practice and poses a security risk. Is there any way of doing this without an account having to be logged in?

My client reports the Jitsi Videobridge for Spark plugin with a version 0.0.1 - is this correct? When I try to chat with someone with the Jitsi Videobridge option, I get:

HTTP ERROR 404

Problem accessing /ofmeet/. Reason:

Not Found

Again, any thoughts as to why? I am not using ofmmet.

Thanks again.

HTTP ERROR 404

Problem accessing /ofmeet/. Reason:

> Not Found

Again, any thoughts as to why? I am not using ofmmet.

Thanks again.

See http://community.igniterealtime.org/message/238466#238466

The problem with this, is that the session apparently requires that an account be continually logged in. In the real world, this is bad practice and poses a security risk. Is there any way of doing this without an account having to be logged in?

I am not sure I understand what you are referring to. Please provide more detail or a screenshot or something

Sure thing, though I am having trouble separating what may be a server issue from a client issue. The 404 message appaers when I click on the Jitsi Videobridge icon (next to the translation dropdown box) on the Spark client. I’d insert an image here, but every time I try it tells me I need to be loggedf in, even though I am or I wouldn’t be able to edit this!

I am not using ofmeet, so the 404 message confuses me. I use nothing except Spark. I would like to use just a browser if possible, but I don’t think I’m even close to that point yet!

On the server, under Component Sessions, I have the following:

1
jitsi-videobridge.mdlimserv001
JitsiVideobridge
component
conference
3:02 PM
3:02 PM

The way I get this is by running the jvb.bat file. However, if I close the command prompt window, the Component Session disappears. That means that the system wants a user to be logged into the server at all times in order to keep that Session active. That is poor practice. How else can I have the plugin active?

Thanks!