Failure to connect

I have installed OpenFire4.0.2 on LinuxMint 17.1. Webserver is working because is accessible and shows “Apache2 Ubuntu Default Page”. But failure to connect. Why?

Is it running though? Openfire is not related to Apache. Check netstat -a if anything is listening on 9090.

Should I run openfirectl or openfire?


Although this way it will run in console. Eventually you will want to run it as a service.

Ok. It works now but another error occures when I loaded :


Problem accessing /setup/setup-admin-settings.jsp. Reason:

Server Error

Caused by:


The corresponding errors should be logged in <openfire_home>/logs/all.log What’s in there?

Also, try running the setup in a different browser, or in “incognito mode” (if your browser supports it). If that makes a difference, I’d be interested to know what browser you’re using.

Mozilla Firefox and Google Chrome make the same error.

There are some records in the log:

ERROR [pool-1-thread-1]: org.jivesoftware.openfire.container.AdminConsolePlugin - An exception occurred while trying to make available the admin console via HTTPS.


at org.jivesoftware.openfire.container.AdminConsolePlugin.startup(AdminConsolePlug

at org.jivesoftware.openfire.container.AdminConsolePlugin.initializePlugin(AdminCo

at org.jivesoftware.openfire.container.PluginManager.loadPlugin( :447)

at org.jivesoftware.openfire.container.PluginManager.access$300( :68)

and so on.

I use:

java version “1.7.0_95”

OpenJDK Runtime Environment (IcedTea 2.6.4) (7u95-2.6.4-0ubuntu0.14.04.1)

OpenJDK 64-Bit Server VM (build 24.95-b01, mixed mode)

Upgrade to 1.8.0 version of Java. Openfire 4.0.2 doesn’t work with java 7.

Thank you it works now. But it is good idea to write here: Openfire: Installation Guide that openfire4.0.2 needs java8.

Do you have any other user on the server that you know password of?

I have decided it. Thanks.