powered by Jive Software

Fastpath 4.0.0 problems

I installed an openfire server on the primary DNS machine of my domain, and I had fastpath working fine. I then noticed the load was a little high on this machine, so I decided to move it to a development machine and work with openfire/fastpath on that system. To date I’ve not been able to get this working properly. I noticed this in the log messages every time I went to the designated fastpath page for support:

2008.09.03 14:18:36 Closing session due to incorrect hostname in stream header. Host: secure.cat6wired.net. Connection: org.jivesoftware.openfire.net.SocketConnection@efc2d1 socket: Socket[addr=/64.151.74.252,port=37606,localport=5269] session: null

I have the link to the fastpath section pointing to here: https://secure.cat6wired.net:9091/webchat/

Every time I load that page, I get the above message specifying incorrect hostname. OK - so while checking this out I’ve made sure that my /etc/hosts file has as its first entry the above mentioned IP with the FQDN and hostname of the server. 64.151.74.252 is my eth0 adapter, and the website cat6wired.net is hosted on 69.59.146.85. The website has a hyperlink to the above so it will go to the fastpath webchat client, but nothing ever shows up whether I’m logged in or not. I cannot continue to use my DNS server to host this service, so I need some help to get this openfire/fastpath operation setup on the non-DNS machine at the ip ending 252. Any help?

We are working on the same problems you were having. How did you get your openfire port 9091 secure with no certificate errors. When I clicked on your link in IE it did not complain about “There is a problem with this website’s security certificate.”. I have self-signed certificates and even tried our CA signed certificate in openfire admin cp.

Would love to hear how you solved this problem? Is it the keystore thing?

I was able to get security with openfire 3.6.3. I imported our xmpp and wildcard CA signed certificates and it is working.

never will be resolved, giving up