Fastpath - Database update failed. Please manually upgrade your database

Running trial version of Enterprise (version 3.1.1) and Fastpath (version 3.1.2). Receiving this error message when Wildfire Server is started:

Starting Wildfire Enterprise

Found old database version 0 for fastpath. Upgrading to version 1…

fastpath - Database update failed. Please manually upgrade your database.

Starting Spark Fastpath

Experiencing problems with Fastpath not showing agent presence. I am running the embedded DB. Is this easily fixed or is there a way to completely uninstall fastpath and reinstall. Fastpath is not in use in production environment, but Wildfire Enterprise is.

There are some instructions on how to interact with the HSQLDB here : .html#hsql

You could hookup to the db then run the upgrade script manually or delete and reinstall the plugin from the admin console. It is probably better to do the former so you won’'t loose any data.

The upgrade script is located in your Wildfire installation directory \plugins\fastpath\database\upgrade\1\fastpath_hsqldb.sql

Let me know if you have any trouble with this.



Hi Nate,

Thanks for your reply. I’'ve tried deleting the plugin from the web gui amd then deleting the C:\Program Files\Wildfire\plugins\fastpath folder, but each time I reinstall the plugin I get the same settings back, and the same error message.

I’‘m running into a brick wall just trying to open the database manager GUI. Here’'s what I did based on the instructions you pointed me to:

  1. Navigated to C:\Program Files\Wildfire\jre\bin (Where my hsqldb.jar is located)

  2. Attempted to run java -cp hsqldb.jar org.hsqldb.util.DatabaseManager

  3. Got back error that the program wasn’'t valid. So I copied java.exe and java.dll from C:\Program Files\Wildfire\lib to C:\Program Files\Wildfire\jre\bin and tried the same command.

  4. I got this error:

Exception in thread “main” java.lang.NoClassDefFoundError: org/hsqldb/util/DatabaseManager

I can tell you that org/hsqldb/util/ doesn’'t exist on my server. Any advice you could give me?

As I said before - this is a non-production environment. If there is an easy way to nuke the whole fastpath plugin and restart from default settings I don’'t mind that at all.

Message was edited by: bmmolloy

If you just want to nuke it, delete the folder and the fastpath.jar. As far as running the hsqldb management program I was able to reproduce the issue with the included jre. I would install a regular sun jdk and use that to run the hsqldb program. Let me know if you have any more troubles.



Hi Nate,

I had some time to wrestle with this a bit more today, but am still not having any luck I am afraid. I’'ve installed the latest JDK 6 release, but I have no clue what to do with it now. I did try running C:\Program Files\Java\jdk1.6.0\lib\jconsole.jar, but was unable to connect to localhost:9090.

I stopped the server and deleted both the fastpath directory as well as fastpath.jar from the plugins directory, but when I started the server and reinstalled the plugin, the previous settings (and errors) came back.


The old settings will come back because the database tables are still there. You should be able to blow the tables away once you get the hsqldb admin app running. There is a pretty good guide on how to do this on the hsqldb webiste :



Hi Nate,

I’'m sorry to say that connecting to the database and all of the manual operations is a little bit beyond my geekiness. I am going to stick with what I know and just do a fresh install on a different server. I was able to get it installed and running with enterprise/fastpath with no problems whatsoever.

Thanks for your help though!