powered by Jive Software

Fastpath Form UI not working

Openfire 3.5.1

Fedora 8 x86

So I am trying to add another field to the Fastpath form via the FORM UI section in workgroup settings. I added an ‘agent’ field and then saved the changes. But, when I click on the chat icon it still only asks for the defaults (name, email, question)? Does this work for anyone else?

Bump…Noone? Could someone out there just try to make another field in the form and see what happens?

There is seriously not a person out there using fastpath that has added a field to the form?

If noone can confirm the form ui changes work, can a developer look at this and either make it a bug or confirm it works?

I can confirm that is is an issue. Beyond that I am not sure how to fix. There is no category in the issue tracker for me to enter a ticket for this either.

If you reboot your server I think you will find that the field you added is not there anymore. At least it does that on my server. So I suspect it is not really making the modification at all. The other indication of this is you can login without the required field.

Ok I got mine to work and fixed some graphical errors as well. Here is what I did:

  • Create a new folder forms at C:\Program Files\Openfire\plugins\fastpath\web

  • Create a new folder images at C:\Program Files\Openfire\plugins\fastpath\web\forms

  • Copy edit-16x16.gif, delete-16x16.gif, arrow_down.gif, arrow_up.gif, blank.gif from C:\Program Files\Openfire\plugins\fastpath\web\images to C:\Program Files\Openfire\plugins\fastpath\web\forms\images

  • Recreate the new form field

  • Click the Save Changes button (see attachment)

  • Test, it should work.

I am having a problem that is similar (not the same) as the one outlined by jeffreyvsmith above.

I have been unable to fix it following the instructions of Todd Getz. The problem as I have experienced it is as follows: I create a workgroup, and then modify the Form UI. Be it adding/removing, renaming, or changing the field type it works and the changes come into effect instataneously.

Once this is saved however, changes become impossible (even with the added directories outline by Todd Getz). I have been tooling around with this for the last hour or so and this is the best out line as to what is happening that I have come up with. I am running the latest version of Openfire with the latest Fastpath plugin and the latest Webchat plugin running in the latest version Apache Tomcat. I can provide any debug information or any other logs that are requested if anyone can help get this bug isolated and corrected so it can be addressed in the next build.

Thanks!

No help on this then? Oh well…

I know it has lost any financial motivation to keep the project up and running, and I definitely lack the history with the project to obtain a clear perspective on the situation at large, but it sure does seem that Openfire has quickly began to take a turn for the worse following the decision to go OpenSource.

I would much rather they not offer plugins, or release them as beta’s, or do something that gives end users a fair warning as to their unstable nature. As it stands I may try to implement a fastpath solution and just leave it alone (assuming I can get lucky enough to get it up and running as needed as I have ran into a few other bugs that are quite bothersome). I don’t like to critique free projects as I have paid nothing and thus desrve nothing back, but I’m now out a good bit of time as I first figured they had done a port of their enterprise plugin that was spot on, not some buggy bit of after thought.

Anyway, maybe I’m just grumpy and out of line, But one thing is for certain, this whole excercise has me seriously considering another route for a Live Support implementation as well as an ejabbered xmpp server migration.

Cheers!

I reported the issue with the images some time back, There’s even a ticket for it.

No clue why something so simple isn’t fixed. Indeed it seems a bit like QC has taken a huge turn for the worse lately with anything having to do with Openfire, Spark, and Sparkweb for favor of Clearspace ($$$). I tried to give things the benefit of the doubt, but little things here and there combined with pretty much anything having to do with the 3.6.0 release seem to wrap it up.

The solution by @sixthring works. You just need to restart openfire after that and don’t forget to give accurate permission to newly created folders.

I tried to follow your guide, but since i’m using Ubuntu 8.04 it won’t let me create folders or links in the plugins directory.

When i do force it with root user, the folders and/or links that i create are removed after 10 sec.

are you using SELINUX ?

don’t believe so, but how would i check?

I had the same issue months ago and i the only way to solved it that I found was by restarting the entire server.

i’ve restarted the server several times, i have even reinstalled openfire and fastpath. this is definitly a problem in the fastpath code - for now i’m just trying to figure out a work around.