powered by Jive Software

Fastpath Issue -- using 3.07 Beta

I was trying to install 3.07 Beta to test how it would work with Fastpath and such. I currently use OF 3.6 and Spark 2.5.8 with Fastpath and it works just fine. When I tried to install the plugins on my test box with 3.07 the Fastpath service would install, but the webchat would not. I have tried searching and searching but can not seem to find an answer for this other than it might be a issue with webchat and 3.07.

Error I am receiving in error.log:

2010.09.21 12:14:07 Error loading plugin: C:\Program Files\Openfire\plugins\webchat
java.lang.NoClassDefFoundError: org/mortbay/jetty/servlet/Context
at java.lang.Class.getDeclaredConstructors0(Native Method)
at java.lang.Class.privateGetDeclaredConstructors(Unknown Source)
at java.lang.Class.getConstructor0(Unknown Source)
at java.lang.Class.newInstance0(Unknown Source)
at java.lang.Class.newInstance(Unknown Source)
at org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.java :420)
at org.jivesoftware.openfire.container.PluginManager.access$300(PluginManager.java :80)
at org.jivesoftware.openfire.container.PluginManager$PluginMonitor.run(PluginManag er.java:1067)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask$Sync.innerRunAndReset(Unknown Source)
at java.util.concurrent.FutureTask.runAndReset(Unknown Source)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101 (Unknown Source)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodi c(Unknown Source)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknow n Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.ClassNotFoundException: org.mortbay.jetty.servlet.Context
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
… 17 more

I have tried to install the newest JRE and still no luck, also removed all plugins, then installed the service first, then the webchat, and still no luck. Any help would be appreciated, or just finding out it might be an issue with the beta would help as well.

Openfire 3.07 Beta / MySQL Database / Java 6.21 / Windows XP machine

I would just say that you are not alone. I have the same problem… I dont have any answers…