FastPath setup Error - Worked before

I had a previous installation of openfire 3.5.2 working, but noticed that it had some issues about the FQDN because I changed its hostname to suit the certificate I wanted to use. Needless to say this was driving me mad so I re-installed so that Openfire saw the new hostname and used the cert properly.

I had FastPath installed and operating, but after the install I’m getting the below HTTP500 error. I do have JDK 1.6)06 installed, so I’m wondering what’s different from before. If there’s any help that someone can provide on this subject, that would be great.

HTTP ERROR: 500No Java compiler available


Caused by:

java.lang.IllegalStateException: No Java compiler available
     at org.apache.jasper.JspCompilationContext.createCompiler(
     at org.apache.jasper.JspCompilationContext.compile(
     at org.apache.jasper.servlet.JspServletWrapper.service(
     at org.apache.jasper.servlet.JspServlet.serviceJspFile(
     at org.apache.jasper.servlet.JspServlet.service(
     at javax.servlet.http.HttpServlet.service(
     at org.mortbay.jetty.servlet.ServletHolder.handle(
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
     at org.jivesoftware.webchat.SetCharacterEncodingFilter.doFilter(
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
     at org.jivesoftware.webchat.SetupFilter.doFilter(
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
     at org.mortbay.jetty.servlet.ServletHandler.handle(
     at org.mortbay.jetty.servlet.SessionHandler.handle(
     at org.mortbay.jetty.handler.ContextHandler.handle(
     at org.mortbay.jetty.webapp.WebAppContext.handle(
     at org.mortbay.jetty.handler.ContextHandlerCollection.handle(
     at org.mortbay.jetty.handler.HandlerCollection.handle(
     at org.mortbay.jetty.handler.HandlerWrapper.handle(
     at org.mortbay.jetty.Server.handle(
     at org.mortbay.jetty.HttpConnection.handleRequest(
     at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(
     at org.mortbay.jetty.HttpParser.parseNext(
     at org.mortbay.jetty.HttpParser.parseAvailable(
     at org.mortbay.jetty.HttpConnection.handle(
     at org.mortbay.thread.QueuedThreadPool$

Powered by Jetty://

Appears that maybe the plugin installation was bad.

I’ve modified /etc/hosts to include my own hostname just in case (as recomended by another post), but got a slightly different error complaining about /webchat/… missing and no java compiler. So I uninstalled the FastPath webchat, restarted openfire, re-installed FastPath webchat, restarted openfire, and it worked again. What an odd happening!

OK, well, now its not working again… and this time an uninstall and re-install of the plugin doesn’t help.

I’m kinda confused now, because I was testing it earlier, and the darn thing worked, but now I can’t get it to work right. Everytime someone goes to the webchat page to start a session, nothing shows up, no queues, no nothing… can someone help here?