powered by Jive Software

Fastpath Web Chat

I just installed Fastpath Web Chat but after installation compelte, it says click on the image to start it but there were no image there.

So i open http://myserver:9090/webchat and it shows:

List of available workgroups within Fastpath

Click on one of the following workgroups to join.

How do i add a room / workgroup to my users chat there?

thanks

error:

Starting Fastpath Server

28/04/2009 17:49:01 org.jivesoftware.webchat.util.WebLog logError

WARNING: Error retrieving chat setting using key=no_help_text and workgroup=null

service-unavailable(503)

at com.jivesoftware.smack.workgroup.user.Workgroup.getChatSettings(Unknown Source)

at com.jivesoftware.smack.workgroup.user.Workgroup.getChatSettings(Unknown Source)

at org.jivesoftware.webchat.util.SettingsManager.getChatSetting(SettingsManager.ja va:108)

at org.jivesoftware.webchat.util.FormText.getTextSetting(FormText.java:128)

at org.jivesoftware.webchat.util.FormText.getNoHelpText(FormText.java:103)

at org.jivesoftware.webclient.jsp.email.offline_002dmail_jsp._jspService(offline_0 02dmail_jsp.java:47)

at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)

at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1093)

at org.jivesoftware.webchat.SetCharacterEncodingFilter.doFilter(SetCharacterEncodi ngFilter.java:45)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)

at org.jivesoftware.webchat.SetupFilter.doFilter(SetupFilter.java:92)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)

at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)

at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)

at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)

at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:726)

at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)

at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollect ion.java:206)

at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)

at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)

at org.mortbay.jetty.Server.handle(Server.java:324)

at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)

at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.j ava:829)

at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:514)

at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)

at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)

at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)

at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:488)

rasouza@chat.cmtsp.com.br

1 Like

Now i am able to see my workgroups.

I added myself as an agent, but when i try to connect on it using exodus i got this:

This workgroup is currently closed

Is this nice community dead?

No, this nice community is not dead, it just doesnt now anything about your problem or dont have time to look though the forums.

What do you mean by, trying to connect? I dont remember is Exodus working fine with the workgroups, but you can try it with Spark, to rule out the client fault.

Also, you can read this document, maybe this will help a little http://www.igniterealtime.org/community/docs/DOC-1528 and maybe Todd will notice this thread at some time.

Thanks for reply.

I am using spark now.

I am workgroup owner and i add a friend as a memeber, we joined on the workgroup, we can chat each other there but clients are not able to join via web cause http://server:9090/webchat shows the workgroup OFFLINE.

HOW DO I BRING IT ONLINE?

BTW, i wanna buy OpenFire Enterprise.

1 Like

Workgroup is currently active and accepting requests.

But http://server:9090/webchat shows it offline.

How do I fix that?

this only shows workgorup as offline.

;((

Enterprise version is not available anymore.

Wait for Todd Getz to come here or try PMing hime maybe.

What are:

  1. openfire server name
  2. xmpp.domain name
  3. the server certificate names
  4. the DNS a record name for the server

Are:

  1. any members admins of openfire
  2. any members MUC admins/owners

Im sorry to have revived. I have searched high and low for the solutions in this forum.

Have tried some solutions and didnt work. So i am wondering did you find the solution?

I am stuck at the point where it is offline too.

  • OpenFire 3.8.2 (with FastPath Service plugin installed)
  • Spark 2.6.3
  • Apache Tomcat 7.0.19 (with webchat.war installed)

I have Spark and the Admin for OpenFire working.

The problem is to have the web chat working. It says its offline.

And when i add the script, the image is missing.

Even after adding the javascript…the image says offline.

Please Please Please help of i do have to open a new thread.

-----------UPDATE-------------

Fixed my issue.

In case anyone else is having the same problem, try this if it helps.

Earlier i downloaded the ZIP version of open fire. Which is without the JRE.

I did this because I already have JRE on my PC. So then I had the OFFLINE problems.

But then i tried deleting the ZIP and use the EXE version and it seemed to work.

Almost magical.

Probably the ZIP version needed some configuration to be done that i wasnt aware of.

In case youre suggesting the environment variables, ive already had it set.

Ok hope this helps.

Peace!