powered by Jive Software

Fastpath Webchat fails to install

Hi,

the fastpath service is running fine on Of 3.7.1. if i try to install the webchat - even via webchat.war i get this:

2012.03.05 16:48:08 org.jivesoftware.openfire.container.PluginManager - Error loading plugin: C:\SERVER\Openfire\plugins\webchat                                java.lang.NoClassDefFoundError: org/mortbay/jetty/servlet/Context                                     at java.lang.Class.getDeclaredConstructors0(Native Method)                                     at java.lang.Class.privateGetDeclaredConstructors(Unknown Source)                                     at java.lang.Class.getConstructor0(Unknown Source)                                     at java.lang.Class.newInstance0(Unknown Source)                                     at java.lang.Class.newInstance(Unknown Source)                                 at org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.java:420)                                 at org.jivesoftware.openfire.container.PluginManager.access$300(PluginManager.java:80)                                 at org.jivesoftware.openfire.container.PluginManager$PluginMonitor.run(PluginManager.java:1067)                                     at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)                                     at java.util.concurrent.FutureTask$Sync.innerRunAndReset(Unknown Source)                                     at java.util.concurrent.FutureTask.runAndReset(Unknown Source)                                     at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(Unknown Source)                                     at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodic(Unknown Source)                                     at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknown Source)                                     at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)                                     at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)                                     at java.lang.Thread.run(Unknown Source)                                Caused by: java.lang.ClassNotFoundException: org.mortbay.jetty.servlet.Context                                     at java.net.URLClassLoader$1.run(Unknown Source)                                     at java.security.AccessController.doPrivileged(Native Method)                                     at java.net.URLClassLoader.findClass(Unknown Source)                                     at java.lang.ClassLoader.loadClass(Unknown Source)                                     at java.lang.ClassLoader.loadClass(Unknown Source)                                     ... 17 more

What went wrong?

Cheers!

Try the attached webchat.war.
webchat.war (2232143 Bytes)

1 Like

Thank you! Works like a charme! Whats the difference here?

Glad it works for you. I had the same problem and found the webchat.war in this support forum. But I don’t remember exactly where I got it.

Thanks

thank you, thank you … you saved my butt wahooooooo! it works!!! my server died and had to install new version and their webchat obvioulsy quit working and now it will be fixed finallly thks

Thank you! I have just downloaded this as well. It said it installed successfully with 3.9.2 . I will let you know if it works. Thanks again!

edit: 439pm

works great! Thank you so much!

This version works fine for me also though I will have to make some changes. I got the code from here

If I build and deploy this war file it doesn’t start correctly.

The issue is when a user clicks on the link to start a chat they

enter their information ie name, email and question. They then go to a

screen telling them they are in a queue, see below screenshot.

The page sticks at this point. While this is happening the user details go

to the queue in spark, I accept the user and the conversation starts on

the agent end but the initial user does not get the IM window. This all

works fine with the war file i downloaded in one of the previous posts.

Is there any place to get working code? Any help here appreciated.

Thanks,

Robert

Try this:

So I was also running into this originally on Openfire 3.9.3. This is everything I did to fix it, but I do not know which one exactly fixed it:

  1. Deleted default queue.
  2. Made new queue (i.e. Support)
  3. Make sure under group chat, group chat settings, that the administrator of the group chat IS NOT the agent that will be receiving notifications.
  4. Under Default Room Settings, make sure that “Make Room Moderated” is unchecked.
  5. After all of this, Stop your Openfire server, wait 10 seconds, and Start it again.
  6. Also, I had to delete the webchat.war plugin and install it again. After you install it, restart server. Then immediately go to http://URL:7070/webchat to set-up the webchat functionality.
  7. If for some reason after all of this, you still cannot connect, a port is probably not open.
  8. Keep me posted if this helped or not!
    I posted this on my post that can be found here: Call jivelive.jsp on Saturday only

Thanks for your response. I tried this and it still doesn’t work. I don’t thin it’s a port issue as the war file above works.

Any other ideas would be greatly appreciated

Actually think I have solved it. I noticed that the chat window had some 500 errors when it was trying to load the queue. This was for the chat.js and engine.js both served by DWR. I check and seen that the DwrServlet wasn’t started due to a log class not cast to the correct type. After a small investigation I found that this was due to the commons-logging.jar being in the WEB-INF/lib folder, I deleted this and everything works as it should.

Roll on to the next issue!

1 Like