powered by Jive Software

FastPath''s webchat.war Java Version?

Has the minimum required Java version changed for FastPath 3.2 webchat.war? I am trying to compile and run this and keep getting the following error for both 3.2 and 3.2.2.

Failed to load servlet: java.lang.LinkageError: LinkageError while defining class: com.jivesoftware.webchat.FastpathServlet

Could not be defined due to: com/jivesoftware/webchat/FastpathServlet (Unsupported major.minor version 49.0)

java.lang.UnsupportedClassVersionError: com/jivesoftware/webchat/FastpathServlet (Unsupported major.minor version 49.0)

It looks like classes within this war were compiled under Java 1.5. I need to deploy this on WebSphere 5.1.1. Java version = J2RE 1.4.2 IBM Windows 32 build cn1420-20040626 (JIT enabled: jitc), Java Compiler = jitc, Java VM name = Classic VM

The minimum version for webchat is 1.5. As of the 3.2 release, all components are compiled against, and require, 1.5.