powered by Jive Software

File transfer error - Spark 2.9.x

Sorry to open another post about this problem, but I may have discovered something …

After much research on this problem. And every new thing gets even more complicated, because one hour it works and then it stops.

First, I have OpenFire 4.5.3 and Spark 2.9.2

I tried everything, however, after the comment of NWilli221 (Transfer Guard allowing files that are blocked), I decided to open it with Notepad the Spark properties file in the “C: \ Users \ USER \ AppData \ Roaming \ Spark \ spark.properties” folder.

In this file you can list all the settings of the App. Among them, there is “downloadDirectory =”. I found it strange because it is necessary to duplicate the “” in the path (if you save the file with only one “”, Spark recognizes the path as if there were no “”, but the biggest problem is that right after the “C” “, before”: “, only one” \ "is placed.

I saved it on my pc without this “” after the “C”. So, I received a file normally. However, when trying to perform the procedure on the computer on my side (same settings and same network), as soon as I log in to Spark again, this “” is added automatically, and this user is unable to receive files.

Update: After a few minutes, I checked and “” appeared again in my properties. So, I stopped receiving files.

Any idea?

This seems to be a bug in the way how settings are saved by Spark, when running on Windows. @wroot can you reproduce this?

I’m sorry, seems that I’ve forgot to put the backward slashs…

I think i can’t reproduce it. For me in spark.properties it shows file path like:

C\:\\Users\\wroot\\Documents\\Downloads

And it only added another slash when i tried to add second slash after C. Then it became C\\\. But once i deleted two slashes it stayed as C\: between restarts.

Slash after C seems strange, but path looks ok in Preferences. I guess some escaping.

Can’t fully test this as file transfer is borked since 2.8.x and is not working reliably between subnets. But at least it creates a placeholder file in that directory.