powered by Jive Software

File Transfer problem between 2 servers behind a NAT

Hi:
I’m having trouble trying to make File Transfer between 2 servers work, they are both behind a NAT.
The Chat worked fine, but the File Transfer didn’t.
Any help is appreciated

Try another client. Spark is known to have troubles with file transfer not in the same subnet.

1 Like

Spark IM Client does not belong to the same company as Openfire?
It’s a shame to have to use another client for file transfers on different subnet (which are well designed on the Openfire server).
Thanks for the answer, the 2nd client I tried worked for me (Pidgin), anyway I would like to be able to use the Spark IM Client which is from the same company (Tried with version “spark_3_0_0-20210605” and it still doesn’t work).

There is no official company (like board, staff, directors, budget). Just a community of open source users. Well, there is also Ignite Realtime Foundation, but this is mostly to cover legal stuff. Openfire, Spark, Smack and other things do belong to the same community, but there are no formal dev teams. Most contributors here work on Openfire project, a few for Smack. Unfortunately Spark was always less popular project in a sense of developers contributing to it. Sometimes one or a few developers work on it for a while, but then move on, sometimes it could be a year of nobody working on it. So, it could be that this file transfer issue will not be addressed soon, if ever. So, if you really rely on file transfer, i suggest to pick another client. Although, i would suggest Gajim. In my opinion a more polished client with good development progress recently.

1 Like

I tried with Gajim but I had trouble connecting to one of the servers and continued with the next Pidgin (my goal was to see if the file transfer worked)

I apologize for calling you “Company” when you are a “Community”, my mistake.

By the way, I would like to congratulate you for this great project you have, at least in my country I know that many companies and cummunities use Openfire as a communication platform (both internal and external).

Hopefully one day the Spark that belongs to your community will be able to make the necessary arrangements for it to be at the same level as other XMPP clients.

CONGRATULATIONS AGAIN

1 Like

Thanks. And i didn’t get offended or anything :slight_smile: Just wanted to explain the situation and difference. I have used Openfire (and later Spark) for many years on my job as well. That’s how i got involved here.

1 Like

I have about 15 branch offices and everywhere file transfer works.
Try enabling File Transfer Proxy.


and I turn off IBB in Spark

I have this configuration in my environment, on Spark does not work File Transfer, on Pidgin works. :thinking:

Do you have your servers behind a NAT too?

I am using dmvpn (cisco) to connect the networks and one Openfire server. Probably the problem is that you have two Openfire servers. I am at a loss to answer why file transfer does not work for you …

I WISH TO APOLOGIZE for making you waste your time on something that at the time I could not test well.

The tests I was doing in my work environment:

  • In one of the domains I was simulating the DNS entry to the other Openfire server (at that time I could not make the change in the central DNS).

Today I was able to make the change in the DNS and the File Transfer worked !!! (with Spark 2.9.4)

Thank you guys for the time you dedicated to my problem.
You are a great community, congratulations on your hard work and I’m sorry for the inconvenience caused.

(how can I mark this topic so people who see it know it’s not a problem?)

1 Like

You already marked a post as Solution, so whole thread is marked as resolved.