File transfer woes

I am seeing an issue on multiple, unrelated opefire installations where file transfers do not work properly. they are running 3.4.4 and have had the same issue on previous versions. in case it is a client issue i have attempted to use multiple clients (pidgin on linux, ichat and adium) none seem to work. i also checked the error logs during the attempt to transfer a file and see nothing. Basically here is the outline of what i did to test:

  1. initiate the transfer2) receiver accepts file 3) check the logs and none are produced 4) file does not transfered

I have also verified that port 7777 is open in the firewall.

Let me know if you need any more info to help me diagnose the issue.

I assume you are trying to do transfers between openfire users not gateway users (AIM, MSN, Yahoo)? Are there any error logs in the debug log of the server or the error logs of the client. Have you tried with spark?

correct, this is between xmpp users not aim or etc.

the debug log is empty.

we have not tried spark since it is not being used in anyones environment. changing clients is not an option for most of our users.

I’m having a similar problem with Wildfire 3.5.1 server and Exodus clients. Port 7777 is being forwarded to the Wildfire server (TCP), and I’ve specified the server as the transfer proxy in the File Transfer section of the Exodus client (e.g., “”). A user will initiate a file transfer, the recipient will specify a download location, but after trying to establish connection to an internal IP address (this transfer is being performed over the Internet), the process will error out.

Anything obvious that I’m missing here?

EDIT: prefixing “proxy.” to the File Transfer Server field (e.g., “”) got it to connect and transfer!