powered by Jive Software

Focus & jvb user offline, pade meeting, pade server 1.2.1, openfire 4.6.0

Hi all,
I am trying to install openfire meetings to have an alternative to Zoom / skype.
Fitst install on a development machine went well and all is functioning, video and audio with 2 connections (one on one meeting)
This install is: openfire4.6.0, pade meetings & server 1.2.1, openjdk- 11-jre, TLS 1, 1.1, 1.2, 1.3

The install on the production server is:
openfire4.6.0, pade meetings & server 1.2.1, openjdk- 8-jre, TLS 1, 1.1, 1.2

The installation went fine, but the service users “focus & jvb” are offline as suppose to be online. Did a restart of both plugins and also a restart of the server. No change.
I can openup the meetings room, but as soon as ones is logging in the connection is lost and retry is underway.

Looking at the logs, I noticed an Authentication error to focus.myjabber.com
My question: is pade meeting & server only running with openjdk -11-jre and TLS 1.3 ?
Or do I have to look somewhere else for the problem ?

If someone could guide me in the right direction, I really would appreciate.

Thank you.

Looking at the logs, I noticed an Authentication error to focus.myjabber.com

If you use default generated passwords, it should be ok. If you manually created the users and set passwords, make sure it matches with these
image

Hi Dele,

thank you for the reply
Both of those users were created bt the system, as it was done the first time on the development machine.

Now I am a bit lost, where do I find your screen shot ? Just looked around and could not find anything. Stupid me :slight_smile:

Meetings | Settings

My advice is to work with the log files until both users are logged in, joined the ofmeet groupchat and both showing green ticks in the summary page. If you make any changes to settings, you may have to refresh the plugin to pick up the changes

Yes I found it just now.
My question again: does it work with java 8 and TLS 1.2 , as these are the only differences between my 2 installations?

Thank you Dele

Yes it does, but I am not a system admin or devop and not tested beyond my dev pc with java8 and my production docker with java14. Also tested with only TLS 1.2

good to hear Dele. Will work on that further and hope to get it working, as it looks really good.

Thank you for your good work!

Dele,

this is part the error log after a new start (not restart) of the server. Can’t post more as new user. :frowning:

2020.12.22 13:29:11 org.jivesoftware.openfire.container.PluginServlet - An unexpected problem occurred while attempting to register servlets for plugin ‘org.jivesoftware.openfire.plugin.MUCServicePlugin@8111cb’.
org.dom4j.DocumentException: Error on line 3 of document file:///usr/share/openfire/plugins/mucservice/web/WEB-INF/web.xml : DOCTYPE is disallowed when the feature “http://apache.org/xml/features/disallow-doctype-decl” set to true.
at org.dom4j.io.SAXReader.read(SAXReader.java:511) ~[dom4j-2.1.3.jar:?]
at org.dom4j.io.SAXReader.read(SAXReader.java:325) ~[dom4j-2.1.3.jar:?]
at org.jivesoftware.util.WebXmlUtils.asDocument(WebXmlUtils.java:32) ~[xmppserver-4.6.0.jar:4.6.0]
at org.jivesoftware.openfire.container.PluginServlet.registerServlets(PluginServlet.java:191) [xmppserver-4.6.0.jar:4.6.0]
at org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.java:667) [xmppserver-4.6.0.jar:4.6.0]
at org.jivesoftware.openfire.container.PluginMonitor$MonitorTask$4.call(PluginMonitor.java:375) [xmppserver-4.6.0.jar:4.6.0]
at org.jivesoftware.openfire.container.PluginMonitor$MonitorTask$4.call(PluginMonitor.java:363) [xmppserver-4.6.0.jar:4.6.0]
at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_171]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_171]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_171]
at java.lang.Thread.run(Thread.java:748) [?:1.8.0_171]
Caused by: org.xml.sax.SAXParseException: DOCTYPE is disallowed when the feature “http://apache.org/xml/features/disallow-doctype-decl” set to true.
at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:203) ~[?:1.8.0_171]
at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.fatalError(ErrorHandlerWrapper.java:177) ~[?:1.8.0_171]
at

I find those entries a bit questionable, or ?

That is an issue with the mucservice plugin. I suggest you remove all plugins except ofmeet and try again.

Hi Dele,

did a new install with just pade plugins installed. Still the same problem.
Error & Warning log is empty, info log gives me this

2020.12.23 14:40:08 org.jivesoftware.openfire.plugin.ofmeet.JitsiJvbWrapper - onOutputLine Error occurred during initialization of VM
2020.12.23 14:40:08 org.jivesoftware.openfire.plugin.ofmeet.JitsiJvbWrapper - onOutputLine Could not reserve enough space for 3145728KB object heap
2020.12.23 14:40:08 org.jivesoftware.openfire.plugin.ofmeet.JitsiJvbWrapper - onProcessQuit 1
2020.12.23 14:40:08 org.jivesoftware.openfire.plugin.ofmeet.JitsiJvbWrapper - Successfully initialized Jitsi Videobridge.
/usr/lib/jvm/java-8-openjdk-i386/jre/bin/java -Xmx3072m -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/tmp -Dconfig.file=/usr/share/openfire/plugins/ofmeet/classes/jvb/application.conf -Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/usr/share/openfire/plugins/ofmeet/classes/jvb -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=config -Djava.util.logging.config.file=./logging.properties -Djdk.tls.ephemeralDHKeySize=2048 -cp ./jitsi-videobridge-2.1-SNAPSHOT.jar:./jitsi-videobridge-2.1-SNAPSHOT-jar-with-dependencies.jar org.jitsi.videobridge.MainKt --apis=rest
2020.12.23 14:40:08 org.jivesoftware.openfire.plugin.ofmeet.JitsiJicofoWrapper - Initializing Jitsi Focus Component (jicofo)…
2020.12.23 14:40:08 org.jivesoftware.openfire.plugin.ofmeet.JitsiJicofoWrapper - allowed external component access
2020.12.23 14:40:08 org.jivesoftware.openfire.plugin.ofmeet.JitsiJicofoWrapper - Successfully initialized Jitsi Focus Component (jicofo).
/usr/lib/jvm/java-8-openjdk-i386/jre/bin/java -Xmx3072m -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/tmp -Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/usr/share/openfire/plugins/ofmeet/classes/jicofo -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=config -Djava.util.logging.config.file=./logging.properties -Djdk.tls.ephemeralDHKeySize=2048 -cp ./jicofo-1.1-SNAPSHOT.jar:./jicofo-1.1-SNAPSHOT-jar-with-dependencies.jar org.jitsi.jicofo.Main --host=jabber.yorktondigital.ca --port=5275 --domain=jabber.yorktondigital.ca --secret=AC5PCoDS3K9MhxgBCCjbqgsfpRKcu4gDSGFPF7Mu --user_domain=jabber.yorktondigital.ca --user_name=focus --user_password=podB42QgfGn9KSNP80e8shcXzATIeRS6KApDQnIX
2020.12.23 14:40:08 org.jivesoftware.openfire.plugin.ofmeet.JitsiJicofoWrapper - onOutputLine Error occurred during initialization of VM
2020.12.23 14:40:08 org.jivesoftware.openfire.plugin.ofmeet.JitsiJicofoWrapper - onOutputLine Could not reserve enough space for 3145728KB object heap
2020.12.23 14:40:08 org.jivesoftware.openfire.plugin.ofmeet.JitsiJicofoWrapper - onProcessQuit 1

Anythoughts on this ?
My system is Debian i386, openjdk-8-jre, Openfire 4.6.0, pade 1.2.1

That looks like you do not have enough memory on your server. I am not a sysadmin, but this my server pade.chat

image

this is strange, as just 10% of my Java memory is used.

system

Are you sure that pade is running with Java 8 ?
Do you need more info logs ?

This is my dev pc running Windows with java 8

image

As you can see, my jvb and jicofo services are up and running

If you know what you are doing, you can change the JVM default settings for Jitsi JVB with Openfire system property org.jitsi.videobridge.ofmeet.jvb.jvm.customOptions

The current default value is
-Xmx3072m -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/tmp

You can also do the same with jicofo (focus user) with
org.jitsi.videobridge.ofmeet.focus.jvm.customOptions

The current default value is -Xmx3072m -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/tmp

Hi Dele,

ok, we are one step closer.
I will lookup this value, and assuming that I have to change -Xmx3072m to a higher value, (is my assumption correct here ?) I would set this to 2-times the amount and hope it will fix my problem.

Could you clearify that for my ?
Thank you.

I think it will have to be a lower value or just remove it and use JVM default

yes it should be lower. I tried with 2 -times and got error, set it to the mentioned value, but still no go.
Here is the part of the info log.

2020.12.24 10:54:34 org.jivesoftware.openfire.container.PluginManager - Successfully loaded plugin ‘admin’.
2020.12.24 10:54:34 org.jivesoftware.openfire.plugin.ofmeet.JitsiJvbWrapper - onOutputLine Error occurred during initialization of VM
2020.12.24 10:54:34 org.jivesoftware.openfire.plugin.ofmeet.JitsiJvbWrapper - onOutputLine Could not reserve enough space for 3145728KB object heap
2020.12.24 10:54:34 org.jivesoftware.openfire.plugin.ofmeet.JitsiJvbWrapper - Successfully initialized Jitsi Videobridge.
/usr/lib/jvm/java-8-openjdk-i386/jre/bin/java -Xmx3072m -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/tmp -Dconfig.file=/usr/share/openfire/plugins/ofmeet/classes/jvb/application.conf -Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/usr/share/openfire/plugins/ofmeet/classes/jvb -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=config -Djava.util.logging.config.file=./logging.properties -Djdk.tls.ephemeralDHKeySize=2048 -cp ./jitsi-videobridge-2.1-SNAPSHOT.jar:./jitsi-videobridge-2.1-SNAPSHOT-jar-with-dependencies.jar org.jitsi.videobridge.MainKt --apis=rest
2020.12.24 10:54:34 org.jivesoftware.openfire.plugin.ofmeet.JitsiJicofoWrapper - Initializing Jitsi Focus Component (jicofo)…
2020.12.24 10:54:34 org.jivesoftware.openfire.plugin.ofmeet.JitsiJvbWrapper - onProcessQuit 1
2020.12.24 10:54:34 org.jivesoftware.openfire.plugin.ofmeet.JitsiJicofoWrapper - allowed external component access
2020.12.24 10:54:34 org.jivesoftware.openfire.plugin.ofmeet.JitsiJicofoWrapper - Successfully initialized Jitsi Focus Component (jicofo).
/usr/lib/jvm/java-8-openjdk-i386/jre/bin/java -Xmx3072m -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/tmp -Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/usr/share/openfire/plugins/ofmeet/classes/jicofo -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=config -Djava.util.logging.config.file=./logging.properties -Djdk.tls.ephemeralDHKeySize=2048 -cp ./jicofo-1.1-SNAPSHOT.jar:./jicofo-1.1-SNAPSHOT-jar-with-dependencies.jar org.jitsi.jicofo.Main --host=jabber.yorktondigital.ca --port=5275 --domain=jabber.yorktondigital.ca --secret=vgCTNn7ckl2C5EDCbb9xBNSTtk098VKN884hGTy5 --user_domain=jabber.yorktondigital.ca --user_name=focus --user_password=rVbXu4aNXEp7oyrjaqGgxEWUBw9G9dBAFX1qsVNR
2020.12.24 10:54:34 org.jivesoftware.openfire.plugin.ofmeet.JitsiJicofoWrapper - onOutputLine Error occurred during initialization of VM
2020.12.24 10:54:34 org.jivesoftware.openfire.plugin.ofmeet.JitsiJicofoWrapper - onOutputLine Could not reserve enough space for 3145728KB object heap
2020.12.24 10:54:34 org.jivesoftware.openfire.plugin.ofmeet.JitsiJicofoWrapper - onProcessQuit 1

What would be the JVM default ?

checked my HeapSize for the JVM and found:
InitialHeapSize = 67108864
MaxHeapSize = 1073741824

-----------
Dele_Olajide

I think it will have to be a lower value or just remove it and use JVM default

----------------

I will try the InitialHeapSize to begin with and will find out. :slight_smile:

PS: new to discourse, how to place a quote proper ?

Use standard markdown

this is a quote

This is a block quote
line 1
line 2

changed the HeapSize to the InitialSize but no go. HeapSize too large. :frowning:

Have removed both plugins. No plugins left, will try a new install. If that does not work, I don’t know where to look at.

You can also do the same with jicofo (focus user) with
org.jitsi.videobridge.ofmeet.focus.jvm.customOptions

The current default value is -Xmx3072m -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/tmp