powered by Jive Software

For those who are waiting openfire-3.3.0 FreeBSD port. (Updated to 3.3.1)

Hello, folks. I know you are waiting for openfire-3.3.1 FreeBSD port, however due to large xorg 7.2 migration process the ports tree is currently on freeze status. But i want to take the opportunity and test the preliminary version of the new port net-im/openfire.

You can download it from here

WARNING: You should deinstall wildfire port before installing openfire.

This is an upgrade procedure from wildfire 3.2.4 to openfire 3.3.1:

  1. Stop the wildfire server if it still running.

  2. Back up setup.

  3. Go to /usr/local/etc/openfire and copy configuration from old setup

a) Copy wildfire.xml and rename it to openfire.xml.

b) Search for org.jivesoftware.wildfire. and replace with

org.jivesoftware.openfire. in openfire.xml

c) Change owner for configurations files:

chown -R openfire:openfire /usr/local/etc/openfire

  1. If using embedded database:

a) Copy and rename files:

/var/db/wildfire/wildfire* files to /var/db/openfire/openfire*

b) Change owner for the database files:

chown -R openfire:openfire /var/db/openfire

  1. Copy old certificates from resources/security directory to same

location in openfire. If you are using self-signed certificates then

regenerate them after start up.

  1. Start up the server using new rc script:

a) Add openfire_enable=“YES” into rc.conf file.

b) /usr/local/etc/rc.d/openfire start

  1. Reinstall the plugins.

  2. If at that point you want to downgrade to wildfire 3.2.4 for some

reason please be sure to reinstall the wildfire port.

Any error, suggestion and successful reports are welcome.

Thank you.

Message was edited by: Nikolay Pavlov

Dear Nikolay,

If it possible, can I contact with You for consultations about FreeBSD&OpenFire ?


BR,

Nongrate

Yes. You can contact me via email quetzal@zone3000.net

Thank you very much for your work on the FreeBSD port!

Some tips for those who are to install it, these are from FreeBSD 6.2-P5:

Just grab these files now and throw them in /usr/ports/distfiles/ , otherwise it will stop the build for them later, slowing you down.

http://www.freebsdfoundation.org/cgi-bin/download?download=diablo-caffe-freebsd6 -i386-1.5.0_07-b01.tar.bz2

http://java.sun.com/javase/downloads/index.jsp -JDK US DST Timezone Update Tool - 1.2.1-

You need a login on the second one, I don’'t think there is a way around it. I already had one from grabbing Solaris a while back.

So now you should have diablo-caffe-freebsd6-i386-1.5.0_07-b01.tar.bz2 and tzupdater-1_2_1-2007f.zip in /usr/ports/distfiles/ .

Untar the openfie port from Nikolay like, tar -zxf openfire20070509.tar.gz -C /usr/ports/net-im/ . Then you can cd into it like a normal port and try to make install clean. Maybe.

This did not work for me. Something todo with the XORG migration? I fixed it with…

###########

BATCH=yes

export XORG_UPGRADE=yes

portupgrade -Rf libXft

portupgrade -a

pkg_delete xorg-manpages*

sh /usr/ports/Tools/scripts/mergebase.sh

############

Two things can fail and its OK (portupgrade -Rf libXft and pkg_delete xorg-manpages*). It just means they aren’'t installed. No big deal. Now back to…

cd /usr/ports/net-im/openfire/

make

make install && make clean && echo ‘‘openfire_enable=“YES”’’ >> /etc/rc.conf && /usr/local/etc/rc.d/openfire start

\o/ \o/ \o/

IT WORKS!

Message was edited by: antinouskalisto

Thanks for good explanation. I should mention that i’'ve updated the version of openfire port in the link above.

There was only a few minor changes in rc script.

Now you can set additional variables in rc.conf for openfire and the most important here is openfire_javargs:

  1. openfire_enable (bool): Set to NO by default.

  2. Set it to YES to enable openfire.

  3. openfire_user (username): Set to openfire by default.

  4. Set it to required username.

  5. openfire_group (group): Set to openfire by default.

  6. Set it to required group.

  7. openfire_libdir (path): Set to /usr/local/share/java/classes by default.

  8. Set it to java classes directory.

  9. openfire_home (path): Set to /usr/local/share/java/openfire by default.

  10. Set it to java home directory.

  11. openfire_javargs (args): Set to -Xmx256M by default.

  12. See java -h for available arguments.