powered by Jive Software

Gaim <-> jive messenger with SSL/TSL

Hi,

Using SSL/TSL from gaim to jive messenger does not work.

I gave seen a few post regarding this problem but no real info on this.

What is the problem? Is the problem with gaim or with jive messenger? Is there any bug reports on this? Solutions?

Thanks

/Magnus

Magnus,

Are there any error messages in gaim that might provide a hint about what the problem is? Other clients seem to work fine.

Regards,

Matt

I’'ve had sucess with Linux Gaim (1.1.2) doing SSL as long as I set “Force old SSL” and set the port to ‘‘5223’’

Ahh, ok. I understand the problem then, and it is a Messenger one. XMPP defines a new way of handling TLS/SSL connections that Jive Messenger doesn’‘t implement yet. We’'re planning on adding support soon.

Thanks,

Matt

I am running Jive on Red Hat 3AS. The connecting clients will most likely be either GAIM or Gush on Windows XP. SSL is a mandate to our messenger solution. I have yet to get SSL to work with either client. I have tried forcing old SSL. Nothing appears to provide even a temporary solution.

Do I need to create my own certs, aside from the 127.0.0.1 cert already present? Am I missing something here?

Please let me know what I can do to get this up and going as quickly as possible.

Many thanks!

I’‘ve been looking at implementing this as well and I’'m in the process of trying multiple clients.

First I’'m using the default certificate cause after all I am testing =-)

After I could not get GAIM 1.1.2 win32 to connect using tls (gives me xml parse error) I tried to force old ssl (gives me an SSL handshake error)

So I tried the psi client and that gave me an error saying my certificate was a self-signed.

I’'m gonna keep trying other clients in the meantime and keep you posted =-)

I just tried gush with tls and that worked fine. =-)

Time to go troll on gaim forums…lol

Hey JoeyBear,

I tried connection with Gush and Psi using the old SSL and both clients were able to connect with the server. But I was not able to connect using Gaim. Don’'t know what validation is Gaim doing. Maybe Gaim is not accepting self-signed certificates? Try using Psi and/or Gush to check that the server side part is ok. Once you are ok with the server you have to check which certificates is Gaim accepting.

Regards,

– Gato