powered by Jive Software

Getting trouble with plugin

Hi,

I have insatlled openfire rpm on my machine (2.6.18-128.el5) using rpm -i and then i have copied kraken.jar to /opt/openfire/plugins directory.

Now after strarting openfire kraken.jar is not auto extracting. But this worked for debian linux version.

Any idea / solution?

Regards,

Samba

Hello,

This sounds like a file permissions issue. Does openfire log anything interesting about trying to work with the plugin? What are the directory permissions for the plugins/ folder and the kraken jar file?

daryl

I have followed these steps to install Openfire and kraken plugin on a 2.6.18-128.el5 machine

  1. Downloaded Openfire rpm using wget http://download.igniterealtime.org/openfire/openfire-3.6.4-1.i386.rpm
  2. Installed Openfire using rpm -i openfire-3.6.4-1.i386.rpm
  3. Downloaded kraken.jar file using wget http://nchc.dl.sourceforge.net/project/kraken-gateway/kraken-gateway/1.1.2/krake n.jar
  4. Copied kraken.jar to /opt/openfire/plugins but kraken.jar is not auto extracted after starting openfire
  5. Then started oprnfire using /etc/init.d/openfire start

http://pim-dev-02.requestec.com:9090/

I have followed the similar kind of steps on defferent machine except the OS platform is debian and using different openfire installer and working OK.

Hi,

I solved this problem by changing the file parmission of kraken.jar using command “chmod 0777 kraken.jar”.

Thanks,

Samba