Google Talk client to work with Openfire


I recently purchased a device which has a builtin Google Talk client based on Jabber. It is possible to configure it to use a different server and set an account it will use to connect. It came preconfigured to connect to on port 5222. I did some research and found Openfire.

My question is if it is possible to get Openfire to accept the connection from this device and initiate communication with it or simply receive what it’s sending and store it in the database?

Thanks in advance!


Openfire has no built in restriction on what clients can connect. It is a matter of whether the gtalk app has been modified to only work with gtalk.

Ah, then I don’t see why it isn’t working. The gTalk app shouldn’t be tied to only gTalk since I can configure it to communicate with another server.

I set it up to use my Openfire server as it’s communication server but I can’t see it logging in. I ran a port-sniffer on the server using port 5222 and I can see the gTalk app connecting on the port but nothing shows in Openfire.

The info that gets sent by the gTalk app before it disconnects is:

<?xml version=‘1.0’ ?>

<stream:stream to=‘myservername’ xmlns=‘jabber:client’ xmlns:stream=‘’ version=‘1.0’>

Where “myservername” ofcourse is the name of my Openfire server.

After that, no communication seems to be occuring at all. I have tried connecting to the Openfire server from a different network with Spark which works fine and from what I can tell it also starts communication in the same way.

I do belive it will work with Openfire somehow but it just seems like it isn’t connecting to the Openfire server even though I can sniff inbound communication from it on the correct port (5222).

Thanks for your reply though, it made me even more confident Openfire should work.


I’ve lurked around and debugged a bit more which has lead to the conclusion that since Openfire doesn’t really support usernames with the character @ in them, my device has trouble logging in. The problem is that I can’t really use a username without @ as it’s enforced by the client on the device.

Is there any way to see failed logins in any of the logs? I have the Debug log turned on but I can’t really tell if there are any failed connections or not.