powered by Jive Software

grantModerator() has no effect on user role change

I am working on Smack-4.3.0 libraries and Openfire 4.2.3. I have a chatroom with an owner and multiple participants. I wish to grant moderator role to a participant user. It works well when I run grantAdmin() which changes the affiliation of the user to admin. However, the role remains as participant. Therefore I run grantModerator(), but when I check on Openfire console, the role remains unchanged as participant.

The exchange between client and server shows that server has successfully added the user to moderator list:

> D/SMACK: SENT (0): <iq to='usergp1@conference.imserver' id='21ihx-396' type='set'><query xmlns='http://jabber.org/protocol/muc#admin'><item nick='241009' role='moderator'></item></query></iq>
> 
> D/SMACK: RECV (0): <iq type="result" id="21ihx-396" from="usergp1@conference.imserver" to="281001@imserver/Smack"/>

May I know what’s gone wrong? Any feedback is highly appreciated!

What you described appears to be more of an server side problem. You may want to bring it up in the Openfire forums.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.