powered by Jive Software

Grey Screen Outside Firewall Openfire 3.7 Win7-64bit Redfire .06 Win7-64bit

I tried my best to read everyone’s resolution for the grey screen problem, but mine seems to be for users outside the network.

I have the following ports open:

5222, 5223, 7070, 7777, 7443, 5229, 3478, 3479

Openfire works great with all my users until I tried to implement redfire.

Initially I installed red5 plugin and of course it is no longer supported. I finally located the Redfire plugin and installed it. Upon reboot of Openfire, I receive the red SLF4J: Class path contains multiple SLF4J warnings in the colsole. I continued and was able to get to the 7070 test page on a workstation behind the firewall and everything seemed to be in order. Installed the latest Spark plugin and still things are just fine.

So when it was time to test it on a user outside the firewall, we get the black grey screen. Thinking it may be something with Spark, I had him run through the test page, more grey. We tried the 2-way and the Screen publisher. Still no dice.

Am I missing an open port from my list above? Or since I am behind a firewall and my server domain is different than my public domain, is there a switch I need to set that corrects that?

Any comments would be appreciated.
error.log.zip (1947 Bytes)
red5.log.zip (978 Bytes)

Redfire uses RTMP (Red5) which always uses port 1935 by default

So I need to install the red5 Openfire plugin as well? Oh, I thought it was no longer used.

Dele:

I opened port 1935 and installed the red5.war in addition to redfire you have listed, and it creates a red5 folder upon launch of Openfire. Still grey screen for user outside firewall. I also have the red error log from the openfire console.

Advice?
errorlog.txt.zip (3569 Bytes)

Well another day passed and I put a few more things together. For one, Red5 1.0 rc1 does not work with Win 7 64-bit. The service would never start up, so I tried Red .9.1 Final and the service started.

Thinking that was the problem, I ran another test and still the grey screen. Hit my limit, I turned to the internet for alternatives. After 30min, I decided to convert my communications server to a Linux server.

Yesterday, was spent looking at all the howto’s and FAQS. After many reinstallations of ubuntu 10.04, I was able to get all my needed services running. (Big Blue Button, Mumble, Openfire, red5)

I am in the home stretch, installed redfire, ran the test page 2v2… Grey screen…

Well, I am glad that I bit the bullet and went linux, Win7 is way to clunky for me as a server. But I still cannot seem to get redfire going. I may just have to settle on using Big Blue Button for the quick video conferences…

The old Red5 plugin and Redfire are the same thing as far as Red5 is concerned. They both have an embedded version of the red5 server listen on port 1935. If you run both at the same time, you will get a clash. The old Red5 plugin will probably not work with Openfire 3.7.0

Dele:

I only have the redfire plugin installed. Well, I must have did something because my user gets the:

“This program cannot display the webpage” error. Either the redfire request is using a behind firewall address or a port is not open.

The following ports are open

5222, 5223, 7070, 7777, 7443, 5229, 3478, 3479, 1935.

FIGURED IT OUT… I am using **comcast **for my ISP and they are blocking port 1935. Will call tomorrow and have them remove the block.

I also opend 1935 port, From my ISP also open this page,

but outside i cant access video its showing check internet coonection,

but everything is fine localy whats the problem

please help me.

Thanks

William