powered by Jive Software

Group Chat History

Using openfire 3.3.2 running on linux box; I used to have a 25 line group-chat history which I didnt want.

Using the Openfire Admin Console, I set the “group chat history settings” to “Don’t show history”. This has meant that nothing new is logged.

However, Whenever I enter a conference room in Spark I see the last 25 lines that were logged before changing that setting.

Personally, I would think that asking for no history should prevent this from happening. Is there any way I can clear the history so that it doesnt appear?

Thanks

You can go into the Database and delete the records from there

Thanks for the reply.

My apologies for appearing ignorant but how do I do that?

Hi Dan, welcome to Ignite Realtime community

However, Whenever I enter a conference room in Spark I see the last 25 lines that were logged before changing that setting.

Are you sure the lines came from the server? I think it’s Spark’s cache.

Personally, I would think that asking for no history should prevent this from happening. Is there any way I can clear the history so that it doesnt appear?

Yep, you’re right. The server should now be mature enough to understand such simple instruction. I don’t think you need to touch the database.

Hi Aznidin,

I am fairly sure it’s on the server. it’s only the group chats (conferences) and i’ve cleared my spark cache entirely. The history appears on any account that joins the conference, whether it was part of that previous conference or not

?:expressionless:

Wonder if the settings for xmpp.muc.history.type=none (it should be). You might also want to try setting xmpp.muc.history.maxNumber=0 although this is actually implied.

xmpp.muc.history.type was already set to none. I added xmpp.muc.history.maxNumber which worked after I restarted the daemon. Thanks for the help

Glad I could help Dan

However I believe there is a bug in the source code. It used to be fine until they added some support for clustering. I think so because going through the source, I saw some parent-child MUC server + some cluster object, which were not there before. My server had been running with the default history strategy. After reading your question I tried to set the strategy to none. Immediately when I looked at the property list I believed I saw xmpp.muc.history.type=0. I tried switching back and forth but couldn’t get back the zero but xmpp.muc.history.type=none. Now I’m doubtful about what I saw :p. Will try to reproduce if I have the time.

Hi,

How you added xmpp.muc.history.type and xmpp.muc.history.maxNumber

and in DB where you added.


Can you tell me file name and syntax.

I m new in openfire. and i have to set xmpp.muc.history.maxNumber=100 instead of default 25.


i tried INSERT INTO OFPROPERTY VALUES(‘xmpp.muc.history.maxNumber’,100) in openfire script.

it didnt worked (eventhough i restarted service)


Thanks in advance.