powered by Jive Software

Groups not showing up no matter the client Server 4.4.0

So I have the latest Spark Client installed 2.8.3, and I have the newest Openfire server installed 4.4.0.

I have AD Sync’d and that is working, users can login. When I go to “groups” and look it shows members inside of those groups. Also when I go to users I see the groups listed for the user.

I have group sharing on (always have).

Since I upgraded to 4.4.0, the groups are not showing up. I only have friends and offline groups that show up in spark. I have also used random XMPP clients with the same result.

I do not know what may have changed. I show “Total Users 1000” which I believe may be inaccurate and possibly why it is not working correctly. Also It has pulled in every computer here (so I know the total user count is way over 1000). I do not believe it used to be this way.

Also someone needs to do something about the group sharing page. The list to select groups to share with should NOT work like that. On top of that, something changed and there is no order to the list. At least if it were alphabetical it would make sense but it’s not and it does not. We have far too many groups out there and a miss-click kills all the previous selections. I am very displeased at this version of Openfire with the problems it has given me. I hope there is a fix for this. I am off right now to the Spark page to report issues there I have with Win10 and 2.8.3.

What specifically is not working correctly? Other than what you described below.

On top of that, something changed and there is no order to the list.

https://issues.igniterealtime.org/browse/OF-1820

Probably not related, but maybe you have similar errors in the logs https://issues.igniterealtime.org/browse/OF-1811

You need to set the system property
ldap.pagedResultsSize
to 1000. It’s an oddity with Active Directory to do with paging.

Greg
PS. @wroot may be worth raising a ticket so that gets set automatically when LDAP is set up for AD.

https://issues.igniterealtime.org/browse/OF-1821

1 Like

Well like I said. If you are on the page that lists the groups I can see say IT_Department group (AD) and it shows 4 users in it. If I edit that group there are 3 groups of settings: Edit Details, Contact List (Roster) Sharing, and Members of This Group. The Edit Details and Members of this group is listed as “Not allowed: the group account system is read-only” which I expect.

Now when I select “Enable contact list group sharing”, I have three options “Users of the same group”, “All users”, “The following groups:”
If I select Users of the same group and save out and relaunch the client then the group will show up for me and the three others in the IT_Department. HOWEVER, if I select “The following groups” and I go through and choose say “B_Sales” then not only do I not have it anymore but B_Sales also does not see it.

Furthermore, for the group in question if I choose “The following groups” then I would imagine that there would be an implicit “share with same group” however I thought maybe there isn’t so I chose B_Sales and then looked for IT_Department (again the list is NOT in any order) I do not even see IT_Department on the list to be able to select it as well.

Not sure where the logs are but if you tell me I’ll happily look.

Not sure what you are asking here. I see 1000 accounts pulled in. I don’t see “more” than that though. I believe I had to set this property long ago.

Also there seems to be something different because now it has pulled in all the PCs as user accounts.

I will check the setting if you tell me where it is at. I’m not sure where it is.

So I found “System Properties” and searched for ldap and I do not have the property ldap.pagedResultsSize at all. I’m going to create it.

I can’t reproduce this with local groups, so maybe this is AD related https://issues.igniterealtime.org/browse/OF-1822

There is a related ticket for this https://issues.igniterealtime.org/browse/OF-1385 My last comment speaks about own group missing in the list. But currently it always shares it to the own group, when you select some groups, so it doesn’t matter that it is not shown. But i think it should show it, when this ticket is resolved.

Yes, if you don’t see a system property, you have to create it to change its default value.

Either in Admin Console (Server > Server Manager > Logs). Or it might be easier to access/read them by going into Openfire installation folder, logs folder and opening the all.log file.

Thanks @wroot - and apologies. I would have done it myself but was on my mobile yesterday which for some reason hadn’t cached my issues password. I would have forgotten otherwise!

Greg