powered by Jive Software

Groups

Can someone please explain what the groups function does in the Users section.

Groups let you organize users. You can currently do two things with this:

  • Show groups in rosters. All group members will automatically see other group members in their rosters.

  • Send broadcast messages to groups using the broadcast plugin.

In the future, additional functionality will be exposed through groups such as setting role-based permissions, etc.

Regards,

Matt

I know I have probably asked you about this like 20 times before, but where do I get/utitlize this plugin for broadcasting?

Carlos,

It’'s only in CVS at the moment. However, I will make a release tonight along with beta 2.

Thanks,

Matt

P.S. – did you get my private message?

Yes I did, but of course I did not notice it until you pointed it out to me, hehe. I replied back.

Thanks for the explanation. I can now use all the features provided.

I have encountered another problem with Groups. I downloaded beta 2 today. I make a new Group called Support. The only person in it is me. I tick the box to display the roster. However when I login in Exodus it dosen’'t display the group. I added the group manually. It appears but it says 0/0 people are online. Is this a bug in the beta?

Thanks.

I have encountered another problem with Groups. I

downloaded beta 2 today. I make a new Group called

Support. The only person in it is me. I tick the box

to display the roster. However when I login in Exodus

it dosen’'t display the group. I added the group

manually. It appears but it says 0/0 people are

online. Is this a bug in the beta?

Thanks.

This is the expected behavior – it would be a little strange and pointless to show yourself in a roster.

-Matt

If you have more than 1 person in your group and you’'re a member of that group, but no one is being displayed on your roster although you have checked to display group in roster, you need to restart the server. The display group members on roster will not take effect until you do so.

Carlos,

I tried to reproduce the problem without success. Which client are you using? Could you also provide me a step by step to reproduce the problem?

I tried these cases:

Case 1:

. Log in 2 users (with empty rosters)

. Create a group and add both users to the group

Case 2:

. Log in 2 users (with empty rosters)

. Turn “show group in roster” on for the group that already had both users as members

Case 3:

. Log in 2 users (with empty rosters)

. Add a new member (the second user) to the group

Thanks,

– Gato

Gato,

What happened to me yesterday:

Upgraded to beta 2, noticed that beta 2 had a new option to either show or hide groups in roster, by default all of my 5 groups were hidden. I was connected via psi 0.9.3 and my roster was empty. I then proceeded to make all the groups (including the ones I was a part of) to show, and yet my client showed no groups, I closed psi a few times and no luck, I then proceeded to stop and restart the server and when I reconnected all the groups were there.

Let me know what you think.

Hola Carlos,

I still cannot reproduce the problem following the sequence you have described. My only difference is that I’'m not doing an upgrade.

Could you reproduce the problem now?

Thanks,

– Gato

Gato,

Tried to recreate the issue, but this time works just fine. Created a group that was hidden by default, added 2 users into the group, unhid the group and automatically popped up in my roster without having to restart messenger. I don’‘t know why when I upgraded would’'t work.

Thanks!

Ok. Let me know if the problem “strikes” again.

Thanks,

– Gato