powered by Jive Software

Gtalk or other XMPP (Jabber) settings

Hello,

after many trials i have working Gojara with Spectrum2. I am using Openfire with Spark. ICQ transport is working well for me, but i need help with Gtalk or other XMPP (Jabber connections).

I have second cfg file in Spectrum2 for Gtalk with:

protocol=prpl-jabber

type=xmpp

In Openfire admin I see both my transport protocols successfully connected, but when I start Spark i have only ICQ, but no Gtalk logo. So, are there any other settings which I need to put in cfg file for Spectrum2 or something which I am missing? How Spectrum2 detects Gtalk connection? I am using libpurple and in documentation on Spectrum2 website is:

prpl-jabber = Jabber/Facebook/GTalk

But how do I specify, that i want to use Gtalk. And same problem is with type field in cfg file - http://xmpp.org/registrar/disco-categories.html#gateway says nothing about Gtalk.

Can someone with working XMPP transports help me, thank you.

I think spectrum/of does this by looking at the name of the jid. We have our gtalk transport configured like this, with protocol and type like you specified.

Have you set the jid of the spectrum instance to gtalk.YOURDOMAIN ?

Also try setting the Identity name to something like this: Spectrum2 Gtalk Transport

If this does not work try changing protocol to prpl-gtalk (There was some reason why we didnt do it this way, but i cant remember. Maybe there isn’t. Just try it out please )

Beware: when you rename the jid in the config file while the transport is still running, you will have to manually stop it. Use spectrum2_manager stop before changing config files.

**
**

from what i can see, there are no other things you can configure to do this.

Thank you very much, i forgot to set gtalk.YOURDOMAIN. Problem solved, but i have another question about Gtalk. Is anyone using Spark with Google Apps account?

I can connect to my standard Gmail account and use Gtalk with it, but it is not working when I try to login with my bussiness Goggle Apps account.

What should i put into username field, i tried every possible combination of our domain name and gmail.com or talk.google.com, but nothing works.

I think there are some additional configuration steps in Spectrum2 that will be needed.

Ok, solved. Add this to Gtalk cfg file:

[purple]

userdir=/var/lib/spectrum/$jid/userdir

connect_server=talk.google.com

And voila you can login with your Gapps domain account.

Hey, glad you were able to work it out. Added your solution to the guide in the troubleshooting section. Many thanks