powered by Jive Software

GTalkSMS MUC issue

I’ve set up an Openfire (3.7.1) XMPP server on our vps to support the android app GtalkSMS.

The only thing I can’t seem to get to work is MUC.

The room is created but no invite is sent and I recieve the following error.

Unable to send conference room configuration form. Ex: forbidden(403)

GtalkSMS devs says this is a server side issue.

I don’t see any settings that would prevent this from working.

The only disabled setting in Default Room Settings are Make Room Persistent.

I’ve tried it with it enabled but still the same result.

Any ideas?

Check the Group Chat > Group Chat Settings > your service > Room Creation Permissions. Probably should be set to anyone. Though i don’t know how GtalkSMS presents itself to Openfire. Maybe it is not looking as a common user and server denies the request, or maybe request is wrong.

Thanks for the reply, but unfortunately that’s already set to “Anyone can create a chat room.”.

Trying to find a log that actually contains some info. This is the only thing I’ve found in the debug log.

2012.04.10 00:39:56 org.jivesoftware.openfire.nio.ClientConnectionHandler - [/71.66.120.27:58473] Wrap res:Status = OK HandshakeStatus = NOT_HANDSHAKING

bytesConsumed = 571 bytesProduced = 634

2012.04.10 00:39:56 org.jivesoftware.openfire.nio.ClientConnectionHandler - [/71.66.120.27:58473] encrypted buf: HeapBuffer[pos=0 lim=634 cap=634: 17 03 01 00 20 B9 13 D1 33 B3 11 06 E3 B1 35 CB B3 E2 0D 6F 37 47 FB CA 8C 7F 41 6D 1C 20 43 C0 4E 6B 49 40 3D 17 03 01 02 50 9D B4 AE 7B 84 18 60 7F AB 68 61 FD FF 13 16 3C 13 D3 E1 24 0E F9 44 0E 69 FE 5B 40 BB 4A CA 29 FB AE 57 91 39 09 DE DE EC 27 29 37 6D 80 7A D2 55 27 AC 9C 34 D1 38 3D 3B DB 78 AD 17 BD 08 03 76 09 83 9C 8A AB 8A 7F B5 4E A3 4A A2 C6 CE 00 51 5A 3D 2D 51 B0 4C B7 D9 69 E9 4E F2 47 A9 12 59 42 57 E8 77 A5 EE F8 11 B1 CC 64 AF 6A 21 8F 52 51 98 06 F4 29 59 D6 BD EC 70 13 36 31 24 06 95 FB FA A3 51 B7 A5 6E AE C4 E4 14 56 54 F3 DC A5 EB A7 32 4D D5 2E 5B E6 8E 42 E8 5E EB 36 70 D6 E8 C5 C8 A0 2A 71 4A 25 D3 D2 21 E6 5D 4D D0 3D B9 30 4A EA DA 0A 5B 40 43 37 6B C8 F8 02 02 18 FC 0B 16 C2 38 58 82 67 73 D8 9F 19 F6 0F FD FE D6 77 FB C0 60 32 78 F6 19 E1 7A 2E FB 62 BB 2E 4E 03 A1 57 3C 21 D8 BF 0E 4E F3 1D C5 0B 69 1B 6F E9 FB 2D 8F D8 D8 90 F2 BA D8 31 4F 88 00 45 F0 53 97 1E 13 E6 BF 94 18 0B 86 74 FE 8E EC DA 3E FC 55 8D 6C F6 FD 58 C3 B3 66 42 8A 13 AC 81 36 22 68 09 80 3C A0 C6 28 22 3A 27 3E DB E5 BA 01 39 5F 10 49 1A A7 36 CB E5 39 A0 DA A6 29 83 53 7F 43 E4 B2 25 C5 88 FC 70 38 AE D6 CA 76 B8 90 81 D7 27 ED 19 46 28 8C A3 32 DA 27 19 4F 41 77 EA 12 CA 32 45 75 8F A3 5D 17 3A C8 31 39 46 4C 2C 3B B6 44 66 A0 BD 41 42 FA C0 DA 3A 38 AC 20 2A 0B 48 59 A4 5D 0E 4D 60 6F C8 15 A8 7D 0A 95 6C 46 25 AA 08 39 38 B5 08 6C F9 96 BD 0C 49 BC 87 C6 69 A1 23 A8 79 A9 41 19 B7 B1 8D C2 60 6D 7F 7B 3B F5 1A C8 29 62 34 89 03 F8 C5 43 5F 40 A5 D1 13 A1 9B 57 54 75 FA 3B 41 BA 64 8D C0 F1 A4 54 54 C2 D0 3A 9A 4B F6 5C 90 FF E3 05 87 14 7C 1E F9 F0 FC 7C 8E 98 0C 12 E1 DE CE C4 B8 35 6B 1B 2F 08 AD D1 62 40 F1 48 45 04 00 A7 3F 16 50 51 43 A8 6C A1 CF 0D 35 03 06 AE 57 B2 E1 9E 99 9A 02 D6 2F 80 05 48 4B 0E 3F 67 56 C9 09 05 F3 2A D9 59 A6 B0 E3 3D 4F 82 2B 28 62 28 63 AE 6F 65 63 0E 08 38 51 84 D2 E2 93 0F 00 32 7D 20 7A B9 3B 97 78 27 08 90 70 E5 E2 E7 04 8C]

2012.04.10 00:39:56 org.apache.mina.filter.executor.ExecutorFilter - Exiting since queue is empty for /71.66.120.27:55464

2012.04.10 00:39:56 org.apache.mina.filter.executor.ExecutorFilter - Launching thread for /71.66.120.27:58473

2012.04.10 00:39:56 org.apache.mina.filter.executor.ExecutorFilter - Exiting since queue is empty for /71.66.120.27:58473

Could this be the issue?

I’m not good at reading logs and can’t see any pointers in this one.