powered by Jive Software

Gush wont connect to Wildfire

I’‘ve tried Pandion and Spark with wildfire and they connect just fine, but when I try connecting with Gush I get an “Authentication Error”, but I can still create new accounts through Gush. Checking wildfire’'s log, I found this:

2006.01.05 14:24:35 SaslException

javax.security.sasl.SaslException: DIGEST-MD5: test is not authorized to act as test@localhost

at com.sun.security.sasl.digest.DigestMD5Server.validateClientResponse(Unknown Source)

at com.sun.security.sasl.digest.DigestMD5Server.evaluateResponse(Unknown Source)

at org.jivesoftware.wildfire.net.SASLAuthentication.doHandshake(SASLAuthentication .java:187)

at org.jivesoftware.wildfire.net.SocketReader.authenticateClient(SocketReader.java :312)

at org.jivesoftware.wildfire.net.SocketReader.readStream(SocketReader.java:269)

at org.jivesoftware.wildfire.net.SocketReader.run(SocketReader.java:118)

at java.lang.Thread.run(Unknown Source)

I know nothing about java so any help is appreciated.

I am also having this problem.

I cannot connect w/ Gush. Other clients are OK (Trillian & Exodus tested).

I tried creating a new account w/ Gush.

The account was created OK (I can see it in the user list), but still won’'t connect.

Here’'s a bit of the log:

2006.01.26 14:06:22 SaslException

javax.security.sasl.SaslException: DIGEST-MD5: cfors is not authorized to act as cfors@localhost

at com.sun.security.sasl.digest.DigestMD5Server.validateClientResponse(Unknown Source)

at com.sun.security.sasl.digest.DigestMD5Server.evaluateResponse(Unknown Source)

at org.jivesoftware.wildfire.net.SASLAuthentication.doHandshake(SASLAuthentication .java:192)

at org.jivesoftware.wildfire.net.SocketReader.authenticateClient(SocketReader.java :316)

at org.jivesoftware.wildfire.net.SocketReader.readStream(SocketReader.java:277)

at org.jivesoftware.wildfire.net.SocketReader.run(SocketReader.java:119)

at java.lang.Thread.run(Unknown Source)

2006.01.26 14:07:35 SaslException

javax.security.sasl.SaslException: DIGEST-MD5: cody is not authorized to act as cody@localhost

at com.sun.security.sasl.digest.DigestMD5Server.validateClientResponse(Unknown Source)

at com.sun.security.sasl.digest.DigestMD5Server.evaluateResponse(Unknown Source)

at org.jivesoftware.wildfire.net.SASLAuthentication.doHandshake(SASLAuthentication .java:192)

at org.jivesoftware.wildfire.net.SocketReader.authenticateClient(SocketReader.java :316)

at org.jivesoftware.wildfire.net.SocketReader.readStream(SocketReader.java:277)

at org.jivesoftware.wildfire.net.SocketReader.run(SocketReader.java:119)

at java.lang.Thread.run(Unknown Source)

Hey guys,

It seems that Gush detected that Wildfire supports SASL and tried to use the DIGEST-MD5 method but the username that is passing is incorrect. Have you tried contacting Gush developers so that they can fix this problem? Unfortunately, current Wildfire version does not allow admins to disable SASL support or any SASL method in particular.

Regards,

– Gato

Thanks, I will see if anything can be done on the other end (Gush).

I’‘m not exactly sure what’‘s going wrong with Gush, but I know that we’'ve gotten other people around this issue by having them use the “Jabber SSL” option for the connection type in the setup menu. This option obviously by passes the SASL authentication, but at least the connection is still secure.

Regards,

Dudley Carr

Thanks, that worked for me.