powered by Jive Software

Has anyone successfully installed Openfire on 64 bit Windows Server 2012 R2?

Recently tried but no success installing Openfire 4.0.2 on our new 64 bit Windows Server running 2012 R2. (Ran Openfire and Spark on our old 32 bit for years, no problem). Has anyone been able to get it going? Are there any step by step instructions? Any tips helpful.

I just installed 4.0.3 (not 4.0.2) on our 64-bit Server 2012 R2 Azure site. Not sure I can offer much assistance, but it should be possible.

My biggest hiccup was that I decided to go with a separate MySQL DB install as I’ll be using it for other components, and the MySQL installer had some issues grabbing and installing files.

The Openfire install itself was uneventful. On configuration post-install I did get stuck on the final step (assuming it was writing the settings) which was resolved by closing and reopening the browser. My fault, really. I’d launched Chrome and downloaded everything including updating Java, but had not closed it. The error was a Java related one, so I assume the browser had hooked into the older Java installed and on restart used the newer one.

I’m deploying Openfire right now, but had previously installed it about 5 years ago - from experience then, the community was pretty helpful. Hopefully the same can be said these days

Are you getting any specific errors/faults on install?

Not 2012, but it worked on 2008 R2 x64. I also had it installed on Windows 8.1 x64 for testing.

Btw, i’m installing into C:\Openfire (to avoid UAC issues) and run it as a service.