Help about openfire installation and java memory

Hello guys

I am newbie in linux…

Please somebody can explain to me why everytime i run openfire in Centos 4.1 it always appear install again

5 times doing install even in the first time i install and its was succesfully installed.

I noticed this everytime i reboot and run the openfire…

then im searching about on how to increase the java memory the defaukt is 64Mb

i followed the instruction but not working to my system

please anyone can help to me…


it always appear install again

Maybe your conf directory or the file in it are write protected? Attend that the bin/extra/openfired script does switch to user “jive”, even if you start it as root. You should also check logfile in logs directory.

then im searching about on how to increase the java memory

Open bin/openfire and set

INSTALL4J_ADD_VM_PARAMS="-Xms256m -Xmx256m"

This sets the memory to 256 MB, don’t forget to remove the # before the line.


Thanks for your reply:

I used linux centos

you mean i will Open bin/openfire and set this INSTALL4J_ADD_VM_PARAMS="-Xms256m -Xmx256m"

i just want to confirm if this path is correct,(In Centos)


inside of bin it has



I dont know what your mean for, is this the file that im going to open and set some code.

Please Help



If you are on Centos, you should edit your /etc/sysconfig/openfire file and set something like this:

OPENFIRE_OPTS="-Xms256m -Xmx512m"

Editing the scripts in bin/ will cause trouble once you do an RPM upgrade.



i used vi to edit this file /etc/sysconfig/openfire

I already uncomment this #OPENFIRE_OPTS="-Xmx1024"

then i changed it to OPENFIRE_OPTS="-Xms256m-Xmx512"

then i restarted but nothing happen same 64mb on my server information…

please help



Is there a " " (space) between the m-X ?




spacing between of this " ", when i checked the file there is no spacing and between m-X no spacing…



Hello everyone

My problem still cant fix please

help me to resolve my problem…



You need a space in there to seperate the settings.



what do you mean space from where???

="-Xms256m -Xmx512m" <------ like this…


Hi cheesewizz,

Yes, did that not work?



yes still not working even i put space…:frowning:

Please help


Dear cheesewizz,

I found the same problem as you. However, I fixed it by go to edit script directly cause I start openfire with manual command

/opt/openfire/bin/ ==> vi it and goto line

OPENFIRE_OPTS="$ -DopenfireHome=$" then change to… OPENFIRE_OPTS="-Xms1024m -Xmx2048m -DopenfireHome=$"

that help me…

Hello @sang_sorn


Your the man…Im so happy about your suggestion…now my JAVA memory its works fine…

T hank you so much…

I really really appreciate and for those who are reply my questions thank you very much too, you spent ur time to read it my questions…

Thank you…


Wich file do I increase the memory using windows?


In windows I have just create 1 new propertie file in bin folder as this link suggests

as here

@ldove 6 posts since
Jun 29,

Jul 20, 2007 6:30 PM [ldove|m-151475] in response to: glish_dreams

Re: How to \ increase JAVA Memory in Openfire 3.3.2

bq. glish_dreams

  •      For some reason I am not locating these files+
  •      m running

Openfire 3.3.2, Windows XP . using a MySQL DB+

If you are using windows,

in the bin folder under your openfire directory, you need to create/edit 1 of

two files.

If running via the GUI console, create/edit the file
In this file, add the following
If you are running as a service,
copy the file to another file named, ‘‘openfire-service.vmoptions’’.
this helps.
Message was edited by: ldove

and it ok for me…

sorry for late.


It worked!

How do I run openfire 3.5.0 as a system service?

you can find it in ll-guide.html

Running Openfire in Windows

If you used the Openfire installer, a shortcut for starting the a graphical launcher is provided in your Start Menu. Otherwise, run openfire.exe in the bin/ directory of your Openfire installation. A button on the on the launcher allows you to automatically open your web browser to the correct URL to finish setting up the server:

Windows Service

If you’re running Openfire on Windows, you will likely want to run Openfire as a standard Windows service after initial setup. If you used the Windows installer, a openfire-service.exe file will be in the bin directory of the installation. You can use this executable to install and control the Openfire service.

From a console window, you can run the following commands:

  • openfire-service /install – installs the service.

  • openfire-service /uninstall – uninstalls the service.

  • openfire-service /start – starts the service

  • openfire-service /stop – stops the service.