powered by Jive Software

[help]Can not login with setup tools after setting up

hi all,

I found that I can’t login via admin console after setting up my openfire server by admin account.

my enviroment is:

OS: CentOS5.4

installation sources: openfire-3.6.4.rpm

I set up this server according to the mannual of Ignite document step by step.

  1. check my IP 192.168.13.236/24

  2. rpm -vih openfire-3.6.4.rpm

  3. start server with : /etc/init.d/openfire start

  4. check the status with : /etc/init.d/openfire status

openfire is running

  1. create a database in mysqlserver :

[root@CentOS / ]#mysql -u root -p

password: 123456

mysql> create database openfire;

mysql > quit

  1. import the infrustructure from openfire database template:

[root@CentOS5 database]#cd /opt/openfire/resources/database

[root@CentOS5 database]#cat openfire_mysql.sql | mysql -uroot -p openfire
Enter password:123456

and then check the database status. ok.

mysql> show databases;
±-------------------+
| Database |
±-------------------+
| information_schema |
| blog |
| mysql |
| openfire |
| test |
±-------------------+

  1. check the tables

mysql> show tables;
±---------------------+
| Tables_in_openfire |
±---------------------+
| ofExtComponentConf |
| ofGroup |
| ofGroupProp |
| ofGroupUser |
| ofID |
| ofMucAffiliation |
| ofMucConversationLog |
| ofMucMember |
| ofMucRoom |
| ofMucRoomProp |
| ofMucService |
| ofMucServiceProp |
| ofOffline |
| ofPresence |
| ofPrivacyList |
| ofPrivate |
| ofProperty |
| ofPubsubAffiliation |
| ofPubsubDefaultConf |
| ofPubsubItem |
| ofPubsubNode |
| ofPubsubNodeGroups |
| ofPubsubNodeJIDs |
| ofPubsubSubscription |
| ofRemoteServerConf |
| ofRoster |
| ofRosterGroups |
| ofSASLAuthorized |
| ofSecurityAuditLog |
| ofUser |
| ofUserFlag |
| ofUserProp |
| ofVCard |
| ofVersion |
±---------------------+
34 rows in set (0.00 sec)

mysql> quit
Bye

and test from IE8, http://192.168.13.236:9090

and follow the guidance finished the question(filling the blanks)

and then a login console showing up…

I input account as admin and the password that set before…

then show up this message :

Login failed: make sure your username and password are correct and that you’re an admin or moderator.

Could someone can help me with this issue ? thanks a lot !!!

haha ,my openfire server is OK, I find how to get start with my openfire…

  1. I restarted the openfire server by /etc/init.d/openfire restart

  2. I granted the privilledges to admin as following command in mysql

mysql> grant all on openfire.* to admin@’%’ identified by ‘mypass’ with grant option;

  1. refresh my IE8 and try again.

the problem resolved… thank you …