powered by Jive Software

Help - Local server missing users/groups after update

Guys I did an update to the server to 4.1.6 - all was working fine prior. We have local user database on a pc thats been running great for quite some time but I decided to do an server update anyways… after it completed it I logged into the server page (http://127.0.0.1:9090/index.jsp) but all my users or other info was missing… just one account the admin is listed. I know the data is there as the server is still running and users are still using spark (never shut it down). Im not sure why the Admin page does not reflect them correctly. Could it be pointing or created a different DB during the upgrade. Any info on how to get the server page back to showing my original DB or any other help would be so much appreciated. Thank you in advance as Im at a lost where to start - Steve

Are you on windows? It sounds like you tried to do an inplace upgrade using 64 bit installer with a 32 bit install.

Server runs on win 7 Pro / 64. Not sure how to tell if its a 32 upgrade that ran

which installer did you download?
there are 2 different ones. one is for 32 bit, one is 64. 64 bit installer will not upgrade a 32 bit instance, but will install a fresh instance. you can ususally look at your C:\Program Files (x86)…if you accepted the defaults, you should have an openfire folder. if so, that likely 32bit! IF that is the case, then you can stop all the openfire services. create a backup…and.uninstall openfire… this should not delete your config files or database…then reinstall with the correct arch version.

Based on the download location - the file was openfire_4_1_6_bundledJRE_x64.exe. The openfire folder in Program Files x86 does not reference anything as being 64 or 32 at least not that I could find. Where else would it say if its a 32 or 64… Does it state it in the server itself somewhere…

If you have Openfire folder in Program files (x86) it aready points that you were using 32-bit version. Currently you have two Openfire instances running. One still serves your clients. New one is the one you connect via browser.

I would stop all Openfire related services/launchers. Uninstall 4.1.6 version, then install it again (64-bit) and point to Openfire folder in Program files (x86). This way you will end up with 64 bit app in x86 folder. If it bothers you, you may try doing as speedy suggested. Or install 32 bit version instead.

My biggest concern is losing the current users and groups that we have running in 32… whats do you think is the quickest and safest way to get server back and reading the 32 data. If I run an uninstall openfire I worry that it may take out my good DB… Can I just point this 64 server I have up to the 32 DB folder and call it a day. Sorry dont mean to be a pain but want to be super carefull when it comes to not losing my good db. Also what happens when I shut down the open fire 32 thats running now - will I be screwed.

Thanks (both for the help)

Speedy do you have the steps to create and then restore a backup - after I do reinstall of 64bit

Guys is there a way to just run the old 32 bit - is it technically still in the computer. to be honest I could careless to upgrade at this point. I can worry about that another time later. If the 32bit version is segregated in the program files 86 folder then is the 32 server exe in there also and can I launch that

Is the easiest way to get things running to just download the latest 32 bit and run it - will that work… and automatically get the server up and pointed correctly

If I remove the 4.1.6 but not the 4.1.1 it should not impact the 32bit db correct. then I can just download a 32 bit version run the install and in a perfect world it should not over wright my 32 db in Program Files x86… would you guys agree

Stop Openfire (service and launcher). Uninstall 4.1.6. Start the service (if it is still there) and maybe it will work. If not, download 4.2.1 32-bit and install on top of 4.1.1.

Thank so much for the help… will give it a go in the morning. Thanks again so appreciated Wroot

Sorry never got back - worked as you said… 32 started no issues