powered by Jive Software

Help me to control Openfire on Windows server

Hi Everybody.

I have install software Openfire on the server Domain Controller is nearlly seccessfully, but I logon by Administrator (Domain) or Administrator (local) into the program it can’t and I don’t know how to solution this, I have some picture everybody can see it below to help me.

please help me to solution.

Thanks so much.

best regard.


I can pretty much guarantee that your baseDN is wrong. But there is no way to know from the data entered in those pics. In AD there are only a few actual CNs If you create a folder it is an OU.

I don’t think so, My AD good action everyone can logon into the system, i using LDP.exe to test LDAP. you can see some picture i upload them. I mean i can’t logon by administrator or user AD into the Openfire, Why??? i have doing correct every thing.

Please show me detail to solution.

thanks very much.



LDP.txt.zip (449 Bytes)

As I said your baseDN is wrong.

it should be either dc=abc,dc=vn or cn=Users,dc=abc,dc=vn.

and now for my high horse. you should not be placing created AD content in the default Users CN. you should create OUs and place the users and groups you create in them. This will also allow you to take full advantage of group policy and be granular with it.

http://www.igniterealtime.org/community/docs/DOC-1554

Hi Admin.

I very happy when you reply to me. I really i reinstall and configuration many time, so it can’t logon into the Openfire, i have upload some pictures from server windows 2k3 sp2 AD, server windows 2k3 sp2 (Openfire), i have reading carrefully this by web site http://www.igniterealtime.org/community/docs/DOC-1554 you send for me, please help me to solution another the way.

_thanks very much Admin and Everybody.

best regard





Once again your baseDN is wrong!!! There should be no CN in your baseDN with your current structure. Besides given the fact that all your users are not in the OU domainAccounts it cannot be part of the baseDN either.

Your baseDN should be as I have said before: DC=abc,DC=vn

hi everybody.

I’m very happy when i success config Openfire. i have wrong about baseDN… thanks very much ToddGetz and Everybody.

I have one more question about Avatar with Shark. i want to show Avatar for client, when i choose a picture make Avatar it’s error “Server does not support VCards. Unable to save your VCard.” before i have download plugin ldapvcardavatar.jar and I copy direction install Openfire and I upload plugin but it’s not success, please help to solution this.

thanks so much.

best regards.


That plugin is no loger valid. New versions of openfire support avatars with LDAP natively. Change the system property ldap.override.avatar to true and restart your server.

Thanks Todd Getz. so can you tell me clearly about Avatar ? “Change the system property ldap.override.avatar to true and restart your server” thanks a lot.

best regard

Look in the openfire system properties of the admin web page for the openfire server. If that setting is not there then create it and set the value to true. If it is present set it to true instead of false.