powered by Jive Software

Help, not reading config.xml and/or LDAP

Hello. For some reason, Wildfire does not honor the config.xml settings. At first, I was just trying to setup LDAP authentication, but now, it seems to disregard everything in the file.

Example, you see that I have added the JID ‘‘test’’ to the authorized users. And the user has an account as a user when I view the “users” section of the admin console. And I can login to the server through Spark with the JID ‘‘test’’. However, I get an invalid username/password when I try to log into the admin console. What gives?

My LDAP support is not working either. Am I missing something?

FILE:

Also, there are now context errors or anything in the log files. at the same time, there’'s no hint of the ldap connection package ever eing used/called in the log files either.

Souvent22

I don’'t know where you get

I hope this would help.

Regards,

wmhtet

wmhtet,

Thanks for your reply. yes, I tried that to no avail. Also something else, I turned bebugging on, and it doesn’'t even seem to “try” and autheticate via LDAP. Is there another setting I need to set to enable LDAP authentication?

It may be silly, but are you editing conf/wildfire.xml or config.xml? config.xml will not be read by anything. Also, be sure to check out the LDAP guide here: http://www.jivesoftware.org/builds/wildfire/docs/latest/documentation/ldap-guide .html

The URL above should not have a space in it (its ldap-guide.html not “.htm l”). The fourms seem to want to wrap the long line.

Message was edited by: slushpupie

I am having the exact same issue. had to completely rpm -e this thing and start again. kept parsing information OUT of the xml file. It is getting very frustrating.

The snippet that forces TLS?

Jeff_garner

Message was edited by: jeff_garner

Slushpupie,

Yes, it’‘s the wildfire.xml that I am editing. I’‘ve been through just about every line of the LDAP guide to no avail. I’‘m considering diving into the source. I mean, even though I have LDAP enabled, I it doesn’‘t even show up in the debug log that it’'s even trying to hit my LDAP (Active Directory) server.

Souvent,

I think you have the same exact problem I just got finished banging my head against… the section. Try that out.

HTH

gcase

I have not noticed that .

Souvent22

I have also been thinking to ask you to provide the complete config file using the code tag,

like this /code

regards,

wmhtet

wmhtet,

I aplogize. Here it is:

Also, do you think it could have something to do with kerberos? I’'m not sure if ADS requires keberos authtication when you submit the username/pass for searching/reading the ADS/LDAP tree. Anyone know?

<?xml version="1.0" encoding="UTF-8"?>

/code

Try putting the provider section outside the ldap section:

/code

Gcase, whmth,

Gcase, I can not thank you enough!! Wow! A simple tag placement was the problem. I can’‘t tell you the frustration this has caused me. Everything is working wonderfully now, and I can go on developing :). Thanks again for your responses. Hopefully I can be of help to you guys someday. I know it’‘s a Java-group here, but if you’'re ever in the Drupal neck of the woods, I will most def. return the favor. :). Cheers.

No problem. Like I said, I was running into the same exact problem just minutes ago. The reason I was poking around in the forums in the first place was to figure out why my install wasn’‘t finding any of the usernames from our ActiveDirectory server. The funny thing is I was able to solve my problem by looking at the example code you posted. I had forgotten the section in my config. So you’'ve already helped me out.

Best Regards,

gcase

Souvent22

Could you please mark gcase’'s thread “Answer” ? Cause that is the answer and thus giving him points for the answer.

Regards,

wmhtet