powered by Jive Software

Help please - Can't open web configuration on port 9090 (SOLVED)

Hello

I have been trying like mad to get openfire setup and installed on my Ubuntu 12.04 LAMP server. I have installed sun java 6:


dcerouter_31494:/usr/share/openfire/conf# java -version

java version "1.6.0_33"

Java(TM) SE Runtime Environment (build 1.6.0_33-b04)

Java HotSpot(TM) Client VM (build 20.8-b03, mixed mode, sharing)

dcerouter_31494:/usr/share/openfire/conf# java -version

java version "1.6.0_33"

Java(TM) SE Runtime Environment (build 1.6.0_33-b04)

Java HotSpot(TM) Client VM (build 20.8-b03, mixed mode, sharing)

I have installed the .deb file with absolutely no problems. Openfire appears to be running:


dcerouter_31494:/usr/share/openfire/conf# ps -elf | grep openfire

4 S openfire  2927     1  0  80   0 - 185623 futex_ 13:21 ?       00:00:04 /usr/lib/jvm/default-java/bin/java -server -DopenfireHome=/usr/share/openfire -Dopenfire.lib.dir=/usr/share/openfire/lib -classpath /usr/share/openfire/lib/startup.jar -jar /usr/share/openfire/lib/startup.jar

4 S root     13901  6509  0  80   0 -  1093 pipe_w 13:32 pts/34   00:00:00 grep --color=auto openfire

I have created an empty openfire mysql database


mysql> show databases;

+--------------------+

| Database           |

+--------------------+

| information_schema |

| mysql              |

| mythconverg        |

| openfire           |

| performance_schema |

+--------------------+

5 rows in set (0.00 sec)

I have followed and read every tutorial on the web that I can find. Pointing a browser to port 9090 does absolutely nothing and I’m never presented with the openfire configuration pages - just always a completely blank screen (the status bar continues to read “Transferring data from…” and it acts as if its trying to load, but nothing ever happens. I have tried from the local machine its self, as well as from other machines on the network.

Also, my openfire database is and remains completely empty.

What on earth am I doing wrong? I am very very savvy, have run my own linux servers for 10+ years and have worked on several opensource projects. Why can’t I get a simple chat server working??

Edit…

Just found this in error.log:

2012.08.06 13:42:42 org.jivesoftware.openfire.container.AdminConsolePlugin - Could not start admin conosle server

java.net.BindException: Address already in use

at sun.nio.ch.Net.bind(Native Method)

at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:137)

at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:77)

at org.eclipse.jetty.server.nio.SelectChannelConnector.open(SelectChannelConnector .java:208)

at org.eclipse.jetty.server.nio.SelectChannelConnector.doStart(SelectChannelConnec tor.java:284)

at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java :55)

at org.eclipse.jetty.server.Server.doStart(Server.java:239)

at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java :55)

at org.jivesoftware.openfire.container.AdminConsolePlugin.startup(AdminConsolePlug in.java:166)

at org.jivesoftware.openfire.container.AdminConsolePlugin.initializePlugin(AdminCo nsolePlugin.java:201)

at org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.java :483)

at org.jivesoftware.openfire.container.PluginManager.access$300(PluginManager.java :80)

at org.jivesoftware.openfire.container.PluginManager$PluginMonitor.run(PluginManag er.java:1067)

at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)

at java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:351)

at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:178)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201 (ScheduledThreadPoolExecutor.java:165)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Schedu ledThreadPoolExecutor.java:267)

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)

at java.lang.Thread.run(Thread.java:679)

Well, this happens to me every time! By the time i get frustrated enough to make a post about an issue, about an hour later I get it figured out.

It appears that port 9090 was being used by another service that I’m running, so I just edited openfire.xml and used some custom ports instead.

… This is what clued me in:

netstat -anp | grep 9090