powered by Jive Software

Help setting up Openfire with spectrum/gojara

Am hoping someone might be able to help me setup OF with spectrum/gojara for access to yahoo and gtalk transports.

I have followed your guide at http://community.igniterealtime.org/docs/DOC-2601 and also another athttp://community.igniterealtime.org/thread/46580 but I dont seem to be able to get OF to see spectrum or for spectrum to see gojara.

I installed gojara though the plugin interface and only ticked the bottom 2 options for spark.

I have then enabled the external component settings within OF and added a secret and left the port at 5275.

I have then registered the repo for spectrum and installed spectrum2 and spectrum2-backend-libpurple.

I created a new config file in /etc/spectrum2/transports called yahoo.cfg with the following:

DOMAIN.COM is where I have my fqdn.

  • [service]*

  • server_mode = 0*

  • jid = yahoo.xmpp.DOMAIN.COM*

  • admin_jid = gojaraadmin@xmpp.DOMAIN.COM*

  • password = secret*

  • server = 127.0.0.1*

  • port = 5275*

  • backend_host = 127.0.0.1*

  • users_per_backend=10*

  • backend=/usr/bin/spectrum2_libpurple_backend*

  • protocol=prpl-yahoo*

  • [identity]*

  • name=Spectrum Yahoo Transport*

  • type=yahoo*

  • [logging]*

  • config = /etc/spectrum2/logging.cfg*

  • backend_config = /etc/spectrum2/backend-logging.cfg*

  • [database]*

  • type = sqlite3*

  • [registration]*

  • enable_public_registration=1*

I then started spectrum:

  • sudo spectrum2_manager start*

  • Starting /etc/spectrum2/transports/yahoo.cfg: OK*

When I check external components within OF, it doesnt show.

I checked the log and it shows authentication error:

  • Component: Connecting XMPP server 127.0.0.1 port 5275*

  • Component: Disconnected from XMPP server. Error: Authentication failed error*

Do you know why it would fail on the authenticaiton? Is there anything else I need to setup?

I have tried to replace the host with the private address, localhost, 127.0.0.1 and its hostname, but still nothing.

cat /var/log/spectrum2/yahoo.xmpp.DOMAIN.COM/spectrum2.log
2014-01-23 11:10:29,975 INFO Component: Creating component in gateway mode
2014-01-23 11:10:29,976 INFO SQLite3Backend: Opening database /var/lib/spectrum2/yahoo.xmpp.DOMAIN.COM/database.sql
2014-01-23 11:10:29,980 INFO NetworkPluginServer: Listening on host 127.0.0.1 port 31533
2014-01-23 11:10:29,980 INFO NetworkPluginServer: Starting new backend /usr/bin/spectrum2_libpurple_backend --host 127.0.0.1 --port 31533 --service.backend_id=1 “-j” “yahoo.xmpp.DOMAIN.COM” "/etc/spectrum2/transports/yahoo.cfg"
2014-01-23 11:10:29,980 INFO NetworkPluginServer: Tried to spawn first backend with pid 13678
2014-01-23 11:10:29,981 INFO NetworkPluginServer: Backend should now connect to Spectrum2 instance. Spectrum2 won’t accept any connection before backend connects
2014-01-23 11:10:30,987 INFO NetworkPluginServer: New backend 0x6c9920 connected. Current backend count=1
2014-01-23 11:10:30,987 INFO NetworkPluginServer: PING to 0x6c9920 (ID=)
2014-01-23 11:10:30,988 INFO Component: Connecting XMPP server 127.0.0.1 port 5275
2014-01-23 11:10:30,989 INFO Component.XML: XML OUT <?xml version="1.0"?><stream:stream xmlns=“jabber:component:accept” xmlns:stream=“http://etherx.jabber.org/streams” to=“yahoo.xmpp.DOMAIN.COM” version=“1.0”>
2014-01-23 11:10:30,995 INFO Component.XML: XML IN <?xml version='1.0' encoding='UTF-8'?><stream:stream xmlns:stream=“http://etherx.jabber.org/streams” xmlns=“jabber:component:accept” from=“yahoo.xmpp.DOMAIN.COM”><stream:error xmlns:stream=“http://etherx.jabber.org/streams”></stream:error>
2014-01-23 11:10:30,995 INFO Component.XML: XML OUT e5e9fa1ba31ecd1ae84f75caaa474f3a663f05f4
2014-01-23 11:10:30,995 INFO Component.XML: XML OUT </stream:stream>
2014-01-23 11:10:30,995 INFO Component.XML: XML IN </stream:stream>
2014-01-23 11:10:30,995 INFO Component: Disconnected from XMPP server. Error: Authentication failed error
2014-01-23 11:10:33,998 INFO Component: Connecting XMPP server 127.0.0.1 port 5275
2014-01-23 11:10:33,999 INFO Component.XML: XML OUT <?xml version="1.0"?><stream:stream xmlns=“jabber:component:accept” xmlns:stream=“http://etherx.jabber.org/streams” to=“yahoo.xmpp.DOMAIN.COM” version=“1.0”>

I also see something strange in the backend log, which shows a connection to 10.1.10.12 which doesnt have a proxy or dns and is not related in anyway to the openfire setup. This server is not referenced anywhere in the config of openfire spectrum or the server its self in dns/hosts

13678: 2014-01-23 11:10:30,039 INFO libpurple: prefs:Reading /var/lib/spectrum2/yahoo.xmpp.DOMAIN.COM/prefs.xml
13678: 2014-01-23 11:10:30,040 INFO libpurple: prefs:Finished reading /var/lib/spectrum2/yahoo.xmpp.DOMAIN.COM/prefs.xml
13678: 2014-01-23 11:10:30,040 INFO libpurple: util:requesting to fetch a URL
13678: 2014-01-23 11:10:30,040 INFO libpurple: dnsquery:Performing DNS lookup for 10.1.10.12
13678: 2014-01-23 11:10:30,041 INFO libpurple: dnsquery:IP resolved for 10.1.10.12
13678: 2014-01-23 11:10:30,041 INFO libpurple: proxy:Attempting connection to 10.1.10.12
13678: 2014-01-23 11:10:30,041 INFO libpurple: proxy:Connecting to 10.1.10.12:8080 with no proxy
13678: 2014-01-23 11:10:30,041 INFO libpurple: proxy:Connection in progress
13678: 2014-01-23 11:10:30,041 INFO libpurple: proxy:Connecting to 10.1.10.12:8080.
13678: 2014-01-23 11:10:30,041 INFO libpurple: proxy:Connected to 10.1.10.12:8080.
13678: 2014-01-23 11:10:30,041 INFO libpurple: util:request constructed
13678: 2014-01-23 11:10:30,045 INFO libpurple: util:Response headers: 'HTTP/1.1 200 OK
Server: Apache-Coyote/1.1
Content-Type: text/html;charset=ISO-8859-1
Content-Length: 1050
Date: Thu, 23 Jan 2014 11:10:33 GMT
Connection: close

can anyone help in how they have openfire with spectrum transport setup?

Openfire - 3.8.2

Spectrum - 2.0 from repo

gojara - 2.0

On ubuntu 12.04

Anyone help?

Does anyone have spectrum working for any of the transports?

if you have a working spectrum could you post your config file as an example so I can see what maybe the issue?

thanks

Hi all,

I am still not able to get this working, but had another idea,

Our users within OF are LDAP users from AD.

Could it be that spectrum is unable to login as it cannot create a account within the user database?

Also I have specified sqlite3 within the transport config, do I need to do anything about creating the database?

Within OF I am using a MySQL database, does spectrum need to use the same database?

Any help would be appreciated on this as I am totally stuck at the moment.

Maybe getting closer…

I have found that if I set the JID as yahoo.servername then it will show up as an external component.

However it looks wrong within the components, as it is listed as yahoo.servername.xmpp.domain.com

Within spark it shows the yahoo icon, but when I tried to login with a Yahoo ID, I get an error within spark of “Unable to register with gateway”

Does anyone know why I cannot register to the component? and also why the component is listed with the strange name, maybe this is the issue?

Within gojara I havent set any restrictions on the component.

Hello, sorry for my late answer.

In attachment you have my cfg files from Spectrum.

In example if you use my Gtalk configuration gtalk.cfg you should change these lines:

jid = gtalk.########

######## - your Openfire server name**
**

**
**

admin_jid = gojaraadmin@########

######## - your Openfire server name

password = ########

######## - password which you set in Openfire external components settings



server = ########

######## - your Openfire server name

If you use MySQL for Spectrum you should change all ######## in DB part of configuration file.

I recommend you follow this tutorial http://community.igniterealtime.org/docs/DOC-2601 step by step and then use my cfg files. For me it worked well.
facebook.cfg.zip (1555 Bytes)
gtalk.cfg.zip (1571 Bytes)
icq.cfg.zip (1519 Bytes)