Help to configure intranet(internal) chat server

hi, i have installed and setup openfire 3.6.0 server fully with mysql, in my office linux server i.e. fedora core 9.

now that server has no fully quilified domain name to it. it has a hostname but though it stoped to resolve suddenly. from browser

e.g. http://sagar/

i added host name and i.p. address in my windows client machine. and then it started to resolve the server. (but some days ago, it was working withoud doing so… )

i am using Exodus as a client to connect the internal server (sagar). using username amit@sagar. but it doesn’t works.

please give me all steps to be configure to connect the chat client to my openfire server. or suggest me other good chat client.

Nov 14, 2008 11:53 AM in response to: amit shah

Re: help to configure intranet chat server
*Why is this related to the Jabber University Network? *

The probability to get an useful answer on this is much higher in the “Openfire Support” forum.

However…a few ideas:

1. Are you sure Openfire is running? Are there error messages in the logfiles?

2. Are ports 5222 and 5223 open in your servers firewall? Since it is an Fedora linux, ports are closed by default. For server-2-server connections you will also need to open port 5269.

3. Have to tried to setup your IP address as hostname in Openfire? (you can change the hostname via AdminConsole)

You should create a new discussion in “Openfire Support” and post the link here.

  1. openfire is running… i restarted service after every modification.

  2. in fedora 9 i have disabled the SElinux and iptables services already. how to know the port status are open or not? and which service is running on which port.

  3. let me try to change the hostname with the ip address.

now i am using spark client.

there is a user name test which i have added from admin interface. password is same.

i tried to login using spark from windows client.

user: test

pass: test

server: sagar


host: 192.168…21

port: 5222

it shows invalid username or password.

please tell me what to do.?

also the ports are open

[root@sagar bin]# nc -z localhost 5000-6000
Connection to localhost 5222 port [tcp/xmpp-client] succeeded!
Connection to localhost 5223 port [tcp/hpvirtgrp] succeeded!
Connection to localhost 5229 port [tcp/] succeeded!
Connection to localhost 5269 port [tcp/xmpp-server] succeeded!
Connection to localhost 5280 port [tcp/
] succeeded!
Connection to localhost 5902 port [tcp/] succeeded!
Connection to localhost 5905 port [tcp/
] succeeded!

What about trying

user: test

pass: test

server: 192.168…etc. ?

It’s not enough to set a hostname for a linux box for it to be resolvable in a local network. You have to add it to a local DNS server or to every client’s hosts file. I think you have done it already with you windows machine. Am i right? Have you added it in you C:\Windows\System32\drivers\etc\hosts ? Like:

192.168… servername

You will have to do this for every client computer. Or you can use IP.


what do you think about changing the Openfire System Property xmpp.domain (aka “server name”) to a full qualified and resolvable hostname?


hey all… one great news…

last saturday i had update fedora online. and because of Xserver crash… i restarted the system.

today on monday morning. i tried to connect the server with spark with the same details

user: test

pass: test

server: sagar


host: 192.168…21

port: 5222

it got connected. and then with exodus i tried… its bang… also…


and LG. my quistion was for intranet. so i don’t have a fully qualified domain name.

thought thanks for your advice.

now tell me how to add this service on start up of linux server.

i have intalled the tar.gz file in /opt/openfire/ not rpm.

I’m using almost 3 years old daemon script, which i’m attaching here. It works for me. But i can’t quarantee it will work for you. I have placed it in my rc.d dir and have placed it into a daemons section in my rc.conf file (Arch Linux distribution). So you will have to figure it yourself if you can use it. Also, if you look inside the script, you will find that i have an export for a java path. So, in my case Java is in /opt/java/jre. Also, there is a line

export OPENFIRE_USER=jive

which means that i’m running Openfire with the user “jive”.
openfired (1271 Bytes)

i found rc.d and placed the file in it. but can’t find the rc.conf

and in chkconfig --list still don’t shows the service.

i reboot the server. did not start that service yet.

Hi Amit,

looks like you have a very small intranet. Even at home I use full qualified domain names for my computers. Anyhow they are not public resolvable. Eg for Openfire.


yes very small only 8-10 terminals.

but its done now. i just reboot the machine by mistake and it started in next reboot.


As i said, i use Arch Linux, so you will have to find out how to put this daemon to your startup in Fedora. I’m not familiar with that Linux distribution.

no problem. i will find other solution.

but i want to ask your what is Arch Linux. means what is the differance in it? and what the normal linux being called?

Arch Linux is just another one of the numerous linux distributions (like Fedora, SuSE, Ubuntu, etc.) There are hundreds of distributions in the world. The main difference is in the configuration. Arch has it all in one place /etc and all configuration can be done by editing a few text files (rc.conf is one of them). This can be a hard linux version for a novice, but it is really simplistic and good linux distro. Other differencies can be rolling release system, package manager, i686/x86-64 optimization (no i386), its base install is very small and light (command line only), so i have ran my first Openfire server on a P3 500 Mhz 64MB RAM for 2 years i think (100 users).

There is no “normal” Linux. Linux is a large package of software, composed by an distributor. You may choose that distributor that fits your needs at best. E.g. there are:

  • Ubuntu Linux (for beginners, Desktop systems)
  • Debian Linux (Server systems)
  • Fedora Linux (for beginners, Desktop systems)
  • RedHat Enterprise Linux (for Server systems, partially commercially)
  • CentOS Linux (Server systems, free alternative to RedHatEnterprise, compatible to Fedora)
  • OpenSuSE Linux (for beginners, Desktop systems)
  • Arch Linux (for experts, minimalistic)
  • Gentoo Linux (for experts, full control over everything)
  • DamnSmallLinux (minimalistic Linux, only 50 Mb, running fully in RAM with 128 MB on 486DX)

well i have upgraded the applications from 3.6.0 => 3.6.1 and that u wont belive.

i have updated using rpm of 3.6.1. i had installed tar.gz with 3.6.0

and found the service name openfired in chkconfig --list. also working well.

see how did i do that in

all the best for all openfire users… it’s realy a great application.


Amit Shah