powered by Jive Software

Help with connection to a real domain

Hello please i have a little problem. I pretty much new to this, when i setup openfire server with localhost everything works perfect. But here is the case i want to use a real domain i own, when i add the domain theres no dns error or anthing but when i try to connect the server with a client i get an error. I will attach screenshots to backup what im trying to explain. Unfortuanly im able to upload just one media since im new user on this forum

you’ll likely want to do the following:

for your xmpp domain you want to use ‘example.com
for fqdn, you can use something like ‘xmpp.example.com
then in your dns, you’ll create an A record for xmpp.example.com
from there, you’ll then make your SRV records for example.com

_xmpp-client._tcp.example.com. 86400 IN SRV 5 0 5222 xmpp.example.com.
_xmpp-server._tcp.example.com. 86400 IN SRV 5 0 5269 xmpp.example.com.

1 Like

A record requires a valid ip address instead. I already did these and it still doesnt work for me. I dunno if im doing it wrongly it keep saying Server Host Name (FQDN): chat.example.com ![\ 12x12] [DNS configuration appears to be missing or incorrect.]

give this video a quick watch. dns is discussed in the first few minutes. If it doesn’t help, DM me and we can talk specifics in private.

i did followed the video but i still get the same error @speedy

without details, its hard to help. like screen shots of your configuration, dns records, etc.

but if u put directly your external IP into the client, does it work? u can put just the main domain, example.com as FQDN, maybe this way it works too