powered by Jive Software

Help with initial configuration using LDAP

I am setting up Openfire for the first time on a network using LDAP.

My structure is as follows:

company.dom

|

L__ Admins

| L__ me

|

L__ CompanyName

| L__ Branch1

| L__users

| L__ Branch2

| L__users

I tried the following settings (based off the LDAP guide):

Server Type: Active Directory

Host: ServerName Port: 389

Base DN: cn=CompanyName;dc=company,dc=dom

Administrator DN: cn=Admins,cn=me;dc=company,dc=dom

Password: my password

When I click on “Test Settings” it gives the error:

Test: Connection Settings

Status: Error

Error authenticating with the LDAP server. Check supplied credentials.

Any ideas on what I did wrong?

Thanks!

Pete

try:

Base DN: ou=CompanyName,dc=company,dc=dom

Administrator DN: cn=me,ou=Admins,dc=company,dc=dom

Thanks! That worked great! I was able to finish the installation.

One more question: I want the admins to be listed in the Users as well. Is there a way for me to add that ou to the list as well?

Thanks again!

use a different baseDN such as dc=domain, dc=com.

I changed to the BaseDN and restarted the Openfire service and all the users are listed now. I added the users that were in the Admin OU to the admins, and I am able to log into the configuration site using one of those accounts, but I cannot log into Spark using it. I can login to spark using any of the accounts that were there before, but not the ones from the Admin OU. Does it take a long time for the accounts to be accessable by Spark, but not to log into the configuration site, or is there something else I am doing wrong?

Thanks,

Pete

Ok, I found the problem. My password contains an international character, such as: å é î õ ü, and I guess these can’t be sent when logging in to a client. I tried with both Spark and Pidgin, and neither would let me log in using an international character in the password. As soon as I changed my password to all normal characters I could log in without a single problem.

Pete