powered by Jive Software

High cpu load after upgrading to openfire 4.2.3

Updated to version 4.2.3 some days ago and now i have high cpu load again…the exact same symptoms i had in 3.9.3 and many more reported in versions under 3.10 here:

Apparently the problem was solved in version openfire 3.10.2 by downgrading Mina from 2.0.9 to 2.0.7
https://issues.igniterealtime.org/browse/OF-922

The downgrade in Mina is weird because the high cpu was solved after Mina 2.0.8 so the problem affects the previous versions as we can read here
https://issues.apache.org/jira/browse/DIRMINA-1084

Openfire versions since 3.10.2 has Mina 2.0.7 ( 6 years old! )

I think its time to openfire to get the latest version of Mina

1 Like

Had to revert to Openfire 4.0.2…no problems now…definetly a problem with version 4.2.3

This seems to be connection related…
Spikes occur when a user connects or disconnects to openfire
In the morning and in the evening when people connect/disconnect the cpu spikes up to 350% for quite some time
In the nigth cpu goes down to 0% ( easier to observe the spikes )

The machine serves openfire and 2 sites (with no significant load)

Specs are:
Intel Xeon L5310@1.6ghz
Centos 5
6Gb ram
600 users online
JDK 8
Xmx2048m

here are some logs that i take from the server
nohup_1.out (235.9 KB)
nohup_2.out (317.9 KB)

1st log has 3 dumps in 10 minutes…cpu was high( 100-300%)

2nd log has 5 dumps
dump1 - evening after restart (restarting makes cpu go 100-300% for 10-15m)
dump2 - 10-15m later (0-100%)
dump3 - morning (100-300%)
dump4 - after lunch (100-300%) ending with Exception “GC overhead limit exceeded”
dump5 - after restart

1 Like

Curious how the rest of the upgrade to 4.2.3 went (minus the high cpu load)

We are currently on 3.9.3 and looking to make the jump to 4.2.3

Haven’t experienced any of the high cpu usage you have noted with 3.9.3, but the server is running

Dual Xeon E5-2640 @2.40GHz
Server 2012 R2
8GB Ram
500ish Users