High CPU when I try to add an Asterisk server

I have installed Openfire on my Asterisk server. The presence, chat, etc is working great. I am using Spark as the client.

When I try to add an Asterisk Server in Asterisk-IM I get very high CPU utilization and the server presence never turns green.

If I tail the Asteisk log I can see that the plugin is logging into the manager console.

I am using the internal database and made the modification that is listed on this post - http://www.igniterealtime.org/community/message/161098 and setup my system like http://benperove.com/howto/setup-openfire-chat-server-and-configure-asterisk-im- plugin/ the screencast.

I have tried it from scratch three times all with the same result, the CPU spikes for the Java and Asteirsk process.

Anyone have anything I can look at?



It looks like it was a manager.conf permision error.

I thought I read you only need this permision set:

read = system,call

I added read & write everything and it started working.

Does anyone know what the permisions should be?