powered by Jive Software

Hostnames Not Resolving

Hello,

I am having a problem using OpenFire with DNS names on my intranet.

My setup is pretty vanilla. I am running OpenFire on a Linux machine and using BIND for DNS. I’m using the domain myexample.com for the OpenFire server machine, which is IP 10.0.0.1. I can ping myexample.com from the command line, on my second Linux box AND I can access the OpenFire admin page via a URL with http://myexample.com:9090, so I’m fairly confident DNS is working. In the OpenFire server properties, the domain is set to myexample.com.

The problem is that when I use my chat client (Pidgin), I can’t send messages to users via names like user1@myexample.com. I get a 404 error back from the OpenFire server. (I’ve used another chat client and the problem still happens). However, if I use user1@10.0.0.1 (the server IP), it works. Do I have to setup the DNS records a particular way? Again, when I’m on the OpenFire machine at a terminal, I can successfully type “ping myexample.com” and get a response of 10.0.0.1 back. I can also ping the domain from the client’s machine as well.

Any help appreciated. Thanks.

Hey TrentL,

When you log into the admin console…what do you see in your server name? Is it your IP 10.0.0.1 or myexample.com? Your server name (aka XMPP domain) should be myexample.com and not your IP address. Based on what you are saying it seems like it’s your IP address.

Regards,

– Gato

Hi Dombiak,

On the “System Properties” page, my xmpp.domain property is set to myexample.com.

However, on the “Server Settings” page, the Server Name is set to the ip (10.0.0.1). When I click “Edit Properties”, change the Server Name to myexample.com, and click “Save Properties”, the system says the “Server Properties were updated successfully” but the Server Name has been replaced with the IP address again. In fact, even if I enter junk text for the server name, it just gets replaced with the IP address again.

So is the problem that my Server Name is an IP while my xmpp.domain name is a hostname? Are they both supposed to be hostnames?

Thanks,

Trent

The names should match. Have you rebooted the server since renaming it? You may also need to regenerate the SSL certificates after successfully renaming the server.

OK, we got it working. We had to re-install OpenFire and then make sure the name was myexample.com when doing the installation. Initially, we had set it to the IP.

It seems the lesson here is that you have to choose the domain name during installation. Changing the xmpp.domain property doesn’t seem to have an affect (as far as I can tell).

Thanks for all the advice. You guys got me looking in the right direction.

  • Trent