How do I enable Vcard using LDAP with AD?

Hello! This tool is getting better and better. Well, I used to use ldapvcardavatar but now I see that it´s not working with the new version (3.5.1) of Openfire anymore. Does anybody knows how to setu this feature back?



Never mind, I already discovered. You have to set ldap.override.avatar to true, under System Properties - Server Configuration.

It´s perfect, you don´t even need the plugin anymore.


will this work to migrate the avatars to the new version? I am using 3.3.1 of openfire and the ldap avatar plugin. when I upgrade, can I have it use the same avatar? I would prefer to not even have my users know of the upgrade and it be seemless.

Hello. I am not the developer, but I think that both (plugin and server setting) use the same field to store the avatars, so you don´t have to do anything, just enable the setting and remove the plugin from the new version.

Best regards,