powered by Jive Software

How to change url?

Followed this doc and intalled candy chat plugin. The url looks like this

http://mydomain:7070/candy/candy/example/index.html

How can i change it look like this:

http://mydomain/chat

Any advice would be greatly appreciated

Thanks

what OS and webserver application are you running?

EDIT: maybe check this thread out – I detailed how to configure apache on linux for sparkweb – but process should be almost the same for serving anything on apache…

also, apache on windows has the same config files and settings… so process should mostly be the same as well…

if you’re on IIS (yuck!) good luck :stuck_out_tongue_winking_eye:

http://community.igniterealtime.org/message/228096#228096

Thank you for the replay.

I run Ubuntu 12.04 with Apache and the chat app is Candy Chat. I run 3.8.1 Openfire. I will check that out and get back to with the result.

Thanks again.

my post was for the Red Hat variants (RHEL, CentOS, Fedora, etc)…

for debian variants (Ubuntu, Mint, etc…)

you will need to replace the “yum install” command with “apt-get install”

also note, the apache installation may vary slightly on debian packages, for example the defaul created apache user might not be named “apache” but rather “http” or “httpd” or similar…

the configs and setup should all be the same though…

Thanks again for the info. But reading the first resource , i don’t use SparkWeb i’m running Candy chat as a plugin. and it’s under plugin. i can access it like: http://mydomain:7070/candy/candy/example/index.html

I’m sorry, I’m new to openfire and plugins. and i’m kind confused what i have to run.

On that reference do i need to do the following part? do i have to remove httpd?

EDIT: to undue apache:

sudo chkconfig httpd off

sudo service httpd stop

and if you really want…

sudo yum remove httpd -y

that will cleanup apache and remove it… if you are worried about having the webserver installed…

I have to make sure before messingup apache

Thanks,

no dont do that… this will remove apache from your system completely!

that post was for that particular user who was having some issues with apache possibly conflicting with sparkweb – a different story from what you’re trying to do.

Even though that thread focuses on setting up SparkWeb, it wont matter because my large post (about partway down from the top) details how to configure apache to serve anything really… just remember i wrote it for RHEL not debian stuff, so swap debian-specific commands like do 'apt-get install" instead of “yum install” etc…

essentially you will want to set your DocumentRoot to /var/www/candy/candy/example it looks like (I am not familiar with Candy at all…just a heads up!)…

this will tell apache that whenever someone goes to the server url (mydomain.com) serve whatever is inside that directory starting with the index.html. if you want someone to go to mydomain.com/chat then you will need to setup an Alias i think for that candy directory… or a symlink if you want… either should do the same outcome…

EDIT: just as the other thread, you may have issues with apache fighting with openfire’s embeded webserver application… you might have to change the port that people will use to connect to candy plugin or something, otherwise having the plugin run fromt eh resources directory is the simplest way to go. if you desire more control of things, then use apcahe unless tehre is something hidden in the docs for Candy plugin that you missed for changing teh URL etc…

Message was edited by: Jason

Why not use a vhost file on apache and redirect http://mydomain/chat to

http://mydomain:7070/candy/candy/example/index.html ?

<VirtualHost *>
ServerAlias example.com
redirect permanent / http://www.example.com/