powered by Jive Software

How to compile and generate Spark installer

Hi, ICould someone tell me how to create Spark’‘s installer?. I’‘ve really searched the forums but I can’'t find anything clear or useful on this matter. I have installed install4j, ant… I have Eclipse 3.2 also.

Thanks,

Ignacio

I also want to know.

Who can help us with details?

You can do an ant -f build.xml installer.win from the build directory for installer4j or ant -f build.xml installer.msi for an msi. If you want to do an msi you will have to install advanced installer.

hello ,I use your command but i didn’'t work.

ant -f E:\spark2.5.1\build\build.xml installer.win

what’'s wrong with it? How can I change the build.xml?

What are the error messages? Do you have Installer4j installed? What is the version that you are trying to compile? I think that the build.xml was either changed in 2.5.2 or 2.5.3. I’'d like to help you out, but I need a little more info.

  • Edit -

Also you might want to do a little bit of looking through the forums. I just found this:

http://www.igniterealtime.org/forum/thread.jspa?threadID=21634&tstart=0

It has a post on how to create the installer4j’'s installer.

Message was edited by: spottedcoin

I have ant and install4j installed.And use the verion 2.5.1 of spark to compile.

install4j has been installed on D:\programe files

and ant has been installed on E:\

then I tpye commands:

ant -f E:\spark2.5.1\build\build.xml installer.win

It seems that compile process was successful.

but I encountered other problems.

the error message like this:

installer.win

BUILD FAILED

E:\spark2.5.1\build\build.xml:410 taskdefA class needed by class com.install4j.Install4JApplication can not be found:

com/install4j/apilauncher/SplashScreen$ConnectionException

Should I need to edit the build.xml file?

I think it must !

But I don’'t know where should I change?

Can you tell me the truth?

Make sure that the line:

in build.xml, points to where you installed the install4j files.

I meet new problems.Ther error messages like this:

intall4j:compilation failed. Reason:java.io.FileNotFoundException:could not find JRE bundle.Neither D:\Programe Files\nistall4j\jre\windows-x86-1.6.0.tar.gz nor …

where can i find windows-x86-1.6.0.tar.gz?

Message was edited by: love_peace

Hi love_peace !

I am with same problem… did you find something what it can solve that?

Regards,

candiao

Preparing configuration

Creating media file ‘‘Windows’’:

Collecting files:

Compiling launchers:

Compiling launcher ‘‘Spark’’:

Compiling launcher ‘‘starter’’:

Creating media file:

Zipping custom code JAR file

Identifing components

Adding JRE (windows-x86-1.6.0_01)

Build failed. Reason: java.io.FileNotFoundException: Could not find JRE bundle. Neither C:\Arquivos de programas\install4j\jres\windows-x86-1.6.0_01.tar.gz nor C:\Documents and Settings\p0045109.install4j4\jres\windows-x86-1.6.0_01.tar.gz nor C:\Projeto_Spark\build\installer\windows-x86-1.6.0_01.tar.gz exist.

It looks like installfj is not fully configured. You will have to download the JRE bundle through the install4j IDE. You can look around the help for install4j to find out how.

http://resources.ej-technologies.com/install4j/help/doc/

Hello?

I made installer successfully. If you haven’‘t resolved it yet. You can mail me directly with your error messages attached.I’'ll give you the details.

wy.wing.2006@gmail.com

Good luck ?

windows-x86-1.6.0.tar.gz here:

http://www.alarmspro.com/downloads/jre/

good luck !

Thanks

Hi all,

I tried with install4j demo and the installer works approximatively … The error that I get just at the end of the installation is :

java.lang.AbstractMethodError
at com.install4j.runtime.installer.controller.Controller.executeActions(Unknown Source)
at com.install4j.runtime.installer.controller.Controller.handleCommand(Unknown Source)
at com.install4j.runtime.installer.controller.Controller.start(Unknown Source)
at com.install4j.runtime.installer.Installer.main(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)
at com.exe4j.runtime.WinLauncher.main(Unknown Source)

However, the installation works … But the desinstaller does not.

Anyone has an idea ?

Hey,

i have the same problem. Installer works and deinstaller doesn’t!!!

Hi

u can try using(older vesion of install4j) ** install4j_windows_4_0_8.exe**

Have you tried following all of the steps in the Build a Branded/Skinned Version of Spark document?

I try it, thanks

Regards

Jens

Hi, I’ve read that and I still get the java.lang.AbstractMethodError as above.

My instal4j version is 4.0.5. Is the problem that the install4j file is not compatible?

I succesfully install but get the error upon install and then can uninstall.

Thanks!

Rob

I have followed the document on compiling spark but the I get an error message when i compile in netbeans saying spark library not found.

I dont understand the error message as i did follow the document right.

Can anyone help please.

Thanks