How to config jwchat to connect with wildfire 3.2.0 a''s httpbind

I download wildfire 3.2.0 Alpha from svn wildfire trunk.

I find there is HTTP binding settings on the web page.

But I don’'t know how to config jwchat to connect with this HTTP binding.

Would someone like to help me?

Am I correct in assuming that with 3,2’‘s httbind support Tomcat is no longer needed? I’‘m trying to isolate my configuration problems for getting jwchat working and want to be sure I’'m not way off base.

Tomcat is no longer needed as the capabilities of HTTP binding are now built into Wildfire.



I was just trying the same thing.

I installed the latest nighly build of wildfire 3.2.0

I installed apache2, with jwchat in its wwwroot

then did a RewriteRule http-bind/ http://servername:8080/http-bind/ in the .htaccess file

started and tested wildfire, that seems to work,

with jwchat I can now login to the wildfireserver. that all seems to work, but after a couple of seconds it loses connection, and in the log I see a html page with:

“Too frequent polling minimum interval is 5, current interval -2”

I remember there was a similar issue on the developer forum a couple of weeks/months ago, but the solution was way beyond my technical abilities… Is there an easier workaround now?

I JUST got this working.

I’'m using 3.20 ALPHA (yeah, I know I need to get to the beta version).

After activating the http bind feature, I added the following to to the apache config for my webchat virtual host …

AllowOverride All

ProxyRequests off

ProxyVia off

    ProxyPass /http-bind/[http-bind port]/http-bind/

    ProxyPassReverse /http-bind/[http-bind port]/http-bind/

I also set the following wildfire server properties …

xmpp.httpbind.client.requests.polling = 0

xmpp.httpbind.client.requests.wait = 10


JWChat is not respecting the Polling interval that Wildfire has sent it. Your options are either to configure the polling interval or modify, or file a bug with, JWChat to respect the value.