How to connect AD via LDAPS

Test: Connection Settings

Status: Error

Error connecting to the LDAP server. Ensure that the directory server is running at the specified host name and port and that a firewall is not blocking access to the server.

WARN [Jetty-QTP-AdminConsole-67]: org.jivesoftware.openfire.ldap.LdapManager - Using unencrypted connection to LDAP service!

I turn off the FW, but I cannot solve it. What should I do?

You will need to consult the documentation of your LDAP server on how to configure it to accept encrypted/LDAPS connections.

Generally speaking, the certificate that is used by the LDAP server must be recognized by Openfire. You can do this by adding it, or its issuer, to the Openfire truststore.

Can I disable this warning when I am using LDAP on my local network? How can I disable it?Thank you.

If you want to hide the warning, you can modify the file log4j2.xml in the lib directory. You can use that to configure exactly what is being logged, where. You’ll find some configuration examples in that file. Full documentation is provided at Log4j – Configuring Log4j 2

I would strongly suggest that you configure ldaps and use it. If not, then username and passwords will be passed in clear text.

1 Like

But I do not know how to configure ldaps. Do you have any document about it? Thank you…

no, because it will be different depending what you are using for your directory ( ldap server). Your title indicates you are using Active Directory. I’m sure a quick google search will provide you what you’re looking for.