powered by Jive Software

How to connect to openfire using websocket

I have openfire 4.2.3 setup and running.Try to connect openfire using websocket but showed timeout.


Using ‘ws://localhost:5222/ws/’ is also defeat.

I think websocket uses http ports.

It does, yes. You want ws://address:7070/ws/ or wss://address:7443/ws/ - unless you’ve changed the default ports.

thanks! I had try this way,not useful.Now I use strophe to connect.

Thanks!Now I use strophe to connect.In free time,I’ll try it again.

@gdt where we can reset ports ? wss://address:7443/ws/ is not working for me but
ws://address:7070/ws/ is working .

To get wss working you’ll need to ensure that TLS is enabled (and working) for client HTTP connections through the admin console.

Greg